PRB: Messages Blocked with SQLMail and Exchange Client

Last reviewed: July 11, 1997
Article ID: Q159425
The information in this article applies to:
  • Microsoft SQL Server, versions 6.0 and 6.5
BUG #: 66337 (Windows NT)

SYMPTOMS

If SQLMail is setup with the Exchange client to use a Microsoft Mail Post Office, Compuserve Mail or Internet Mail, outgoing messages will be blocked in the Personal Message Store's Outbox and no incoming messages will be received.

CAUSE

The architecture of the Exchange client does not allow the spooler process to run under a service like SQL Server and hence the messages are never sent or received.

WORKAROUND

There are 3 workarounds for this issue depending on the mail source:

  1. Install Microsoft Exchange Server and set up SQLMail with it, following the instructions in the following article in the Microsoft Knowledge Base:

          ARTICLE-ID: Q153159
    
          TITLE     : INF: Troubleshooting SQLMail with Microsoft Exchange
                      Server
    
       Then have Microsoft Exchange Server forward the mail to the appropriate
       destination.
    
    

  2. If SQL Server is running on Windows NT Server version 3.5x and the mail source is a Microsoft Mail Post Office, uninstall the Microsoft Exchange client and follow the instructions in the following article in the Microsoft Knowledge Base:

          ARTICLE-ID: Q118501
    
          TITLE     : INF: Troubleshooting SQLMail with Post Offices
    
    

  3. Microsoft has confirmed this to be a problem in Windows NT version 4.0. This problem was corrected in the latest Microsoft Windows NT 4.0 U.S. Service Pack. For information on obtaining the service pack, see the following Knowledge Base article:

          ARTICLE-ID: Q152734
    
          TITLE     : How To Obtain the Latest Windows NT 4.0 Service Pack
    
    


Additional query words:sp3 4.00
Keywords : kbinterop kbother SSrvAdmin SSrvGen
Version : 6.0 6.5
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: July 11, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.