3.04 3.10 4.00 5.00 | 3.04 3.10 4.00 5.00 | 3.04 3.10 | 3.04 3.10 4.00
WINDOWS | WINDOWS NT | MACINTOSH | MS-DOS
kbusage kberrmsg kbprb
The information in this article applies to:
- Microsoft Visual SourceSafe, versions 4.0, 5.0
- Microsoft SourceSafe for Windows, versions 3.04, 3.1
- Microsoft SourceSafe for Windows NT, versions 3.04, 3.1
- Microsoft SourceSafe for Macintosh, versions 3.04, 3.1
- Microsoft SourceSafe for MS-DOS, versions 3.04, 3.1
SYMPTOMS
A "Timeout Locking File" error occurs if the SRCSAFE.INI file contains
Lock_Mode = lockfile.
CAUSE
This error indicates a lock file (.LCK extension) exists in the DATA\LOCKS
directory. This situation occurs under either of the following
circumstances:
- A user has a file locked. For example, a file is locked while it is
updated.
-or-
- A SourceSafe lock file has not been deleted from the DATA\LOCKS
directory.
NOTE: To ensure the lock file is not in use, verify all users are out of
SourceSafe before using the second workaround described below.
WORKAROUND
Use either of the following workarounds to resolve this error:
- Increase the Lock_Timeout setting. This method works best in situations
where users are updating large files, or the network is slower than
normal. Increasing this setting allows SourceSafe additional time
before issuing the "Timeout Locking File" error.
-or-
- Check the DATA\LOCKS directory for any undeleted files. If the error
seems to persist, even when no one is running SourceSafe, a lock file
may not have been successfully deleted from the DATA\LOCKS directory.
You can check this directory for old undeleted lock files (.LCK
extension).
NOTE: This error also occurs if the DATA\LOCKS directory has not been
created properly. For additional information, please see the following
article(s) in the Microsoft Knowledge Base:
ARTICLE-ID: Q131445
TITLE : FIX: "Timeout Locking File: UM" Error Occurs at Startup
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