PRB: Unable to Open User Login File

Last reviewed: April 22, 1997
Article ID: Q167262
The information in this article applies to:
  • Microsoft Visual SourceSafe, 16-bit and 32-bit, for Windows, versions 4.0, 4.0a
  • Microsoft Visual SourceSafe, 32-bit, for Windows, versions 4.0, 4.0a, 5.0

SYMPTOMS

In Visual SourceSafe 5.0, the user receives the message:

   Unable to create user login file <LogFile Name>

A similar message occurs in Visual SourceSafe 4.0:

   Access to the file Rights.Dat denied.

CAUSE

These errors occur because the user does not have Write access to the Visual SourceSafe database.

RESOLUTION

The solution to these problems is to grant the user full rights to the Visual SourceSafe directory and all subdirectories.

All Visual SourceSafe users must have the ability to read, write, create and erase files in the Visual SourceSafe directory and all subdirectories.

For additional information, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q131022
   TITLE     : Required Network Rights for the SourceSafe Directories

   ARTICLE-ID: Q149586
   TITLE     : INFO: VSS on Windows NT Workstation w/ FAT Partition

STATUS

This behavior is by design.

MORE INFORMATION

In addition, when you use Windows NT as the server for the Visual SourceSafe database you must make sure that the Share and Directory permissions are the same. In Windows NT, you grant a user access by giving them permission to access a share. You can also control rights to individual directories. If the user has full rights to the directory and read-only rights to the share, he/she will get the error.


Keywords : kbui ssui
Version : 4.0 4.0a 5.0
Platform : WINDOWS
Issue type : kbprb


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: April 22, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.