FIX: SSARC & SSRESTOR Do Not Store Macintosh Resource Fork Data

Last reviewed: December 1, 1997
Article ID: Q172337
The information in this article applies to:
  • Microsoft Visual SourceSafe, 32-bit, for Windows, version 5.0

SYMPTOMS

When using SSARC and SSRESTOR to archive and restore files from a database that has Macintosh SourceSafe clients and stores Macintosh files, the file's resource fork is not included as part of the archive. Restoring the archive to another database causes resource fork information to be lost. Attempting to get or checkout these files on a Macintosh client produces the following error message:

   File '<path>:<filename>' not found where <filename> has either a .c or
   a .d extension.

CAUSE

SSARC and SSRESTOR do not make use of the information stored in files with the .c or .d extension in the SourceSafe database. These files contain the resource fork information for Macintosh files.

RESOLUTION

It is possible to copy the Macintosh resource fork information to the restored database. SSARC & SSRESTOR may re-map the physical filenames when archiving from one database and restoring into another database. The following steps can be used to copy the resource fork information:

  1. Find the physical name of the file in the old database.

  2. Copy the old .c or .d file.

  3. Find the new physical file name for the file in the restored to database.

  4. Rename the old .c or .d file to the new physical file name.

  5. Place the renamed file in the appropriate subdirectory in the restored to SourceSafe Database.

STATUS

Microsoft has confirmed this to be a bug in the Microsoft products listed at the beginning of this article. This bug has been fixed in Visual Studio 97 Service Pack 3.

For more information, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q170365
   TITLE     : INFO: Visual Studio 97 Service Packs - What, Where, and Why

REFERENCES

For additional information, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q131447
   TITLE     : HOWTO: Use PHYSICAL Command to Find SourceSafe Database File

   ARTICLE-ID: Q157714
   TITLE     : How SourceSafe Stores Log Files


Additional query words: mac
Keywords : ssusage VS97FixlistSP3 kbbug
Version : WINDOWS:5.0
Platform : WINDOWS
Issue type : kbbug
Solution Type : kbfix kbservicepack


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: December 1, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.