3.x 4.x 5.0x 5.1x 5.20 5.3x 5.50 5.60 | 5.0x 5.10 5.11 5.13 5.15
MS-DOS | OS/2
kbtool
The information in this article applies to:
- Microsoft LINK for MS-DOS, versions 3.x, 4.x, 5.0x, 5.1x, 5.2,
5.3x, and 5.5
- Microsoft LINK for OS/2, versions 5.0x, 5.1, 5.11, 5.13, and 5.15
SYMPTOMS
An attempt to link a large program fails and Microsoft LINK generates one
of the following messages:
L1084: cannot create temporary file
L1085: cannot open temporary file
CAUSE
The four most likely causes of these errors are as follows:
- TMP environment variable not set or set incorrectly
- Not enough space on drive/directory to which TMP variable is set
- Insufficient file handles available
- Terminate-and-stay-resident (TSR) programs or device drivers
RESOLUTION
The four corresponding resolutions for these causes are as follows:
- Perform the following four steps to verify the TMP environment variable.
a. Use the MS-DOS SET command to determine the setting of the
TMP environment variable.
b. Verify that the TMP variable is set to a valid drive and
directory.
c. In the AUTOEXEC.BAT file, verify that no white space appears
before or after the equal sign (=).
d. In the AUTOEXEC.BAT file, verify that no function or white
space follows the driver and directory
- Use the CHKDSK command to determine how much free space is available on
the drive and directory to which the TMP environment variable points.
(Note that if the TMP environment variable points to the root directory
of a hard disk, the root directory can contain only 512 files.)
- Edit the CONFIG.SYS file and verify that it contains the FILES=<n>
statement. The value of <n> should be at least 20. Verify that no white
space appears before or after the equal sign.
- Make a backup copy of the AUTOEXEC.BAT and CONFIG.SYS files. Edit the
files to remove any TSR programs and/or device drivers. Shut down the
system and reboot. If this step corrects this problem, one of the TSR
programs or device drivers conflicts with LINK. Load one TSR or device
driver at a time to determine which one causes the conflict.
If removing Novell network software corrects this problem, then the problem
may be caused by a conflict between LINK and Novell. The "Network Patches
for Utilities" application note (SC0381) provides LINK version 5.13 to
replace LINK version 5.1. This file has been removed from the Software
Library but can be requested by calling Microsoft Product Support Services.
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