FIX: Data Access Setup Can Give Incorrect Error Message

Last reviewed: October 30, 1997
Article ID: Q100613
3.00 WINDOWS kbinterop kbprg kbbuglist

The information in this article applies to:

- Microsoft Visual Basic for Windows, version 3.0

SYMPTOMS

When adding an SQL server with the Microsoft ODBC Setup program, you may receive the following incorrect message when the server name is actually correct:

   The server <your server name> was not found on the network.
   Are you sure you want to use it?

CAUSE

The cause of this problem has not yet been determined. We are researching it.

WORKAROUND

Although Visual Basic Data Access Setup generates this incorrect message, Visual Basic still adds the correct information to the ODBC.INI file and the ODBC driver is set up correctly.

STATUS

Microsoft has confirmed this to be a bug in the Microsoft products listed at the beginning of this article. This problem has been corrected in Visual Basic version 4.0.

MORE INFORMATION

Steps to Reproduce Problem

  1. Run the Data Access Setup program.

  2. Select SQL Server in the Install Drivers dialog box. Then click the OK button. If the ODBC drivers were installed previously, you will get a message box that asks if you want to replace your driver; choose Yes.

  3. Select the Add option in the Data Sources dialog box.

  4. Select SQL Server in the Add Data Source dialog box, and click the OK button.

  5. In the ODBC SQL Server Setup dialog box, type the name of the data source in the Data Source Name field and a valid SQL server name in the Server field.

  6. Click the OK button. At this point, Visual Basic may generate a message box with the following text

    The server <your server name> was not found on the network. Are you sure you want to use it?

  7. Click the Yes button, and the setup will continue as usual.


Additional reference words: buglist3.00 3.00 fixlist4.00
KBCategory: kbinterop kbprg kbbuglist
KBSubcategory: APrgDataIISAM
Keywords : APrgDataIISAM kbbuglist kbinterop kbprg
Version : 3.00
Platform : WINDOWS
Solution Type : kbfix


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: October 30, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.