PRB: PD*JET.DLL Conflict Compatibility Layer/Crystal Reports

Last reviewed: December 3, 1996
Article ID: Q118627
The information in this article applies to:

- Microsoft Visual Basic Programming System for Windows, version 3.0 - Microsoft Jet 2.0/Visual Basic 3.0 Compatibility Layer - Crystal Report Writer and Crystal Reports by Crystal Services

SYMPTOMS

If you install the Professional Edition of Crystal Reports version 3.0 (or updates to the files CRW.EXE, PDBJET.DLL, PDCTJET.DLL, and PDIRJET.DLL that you received from Crystal Services) and then install the Microsoft Jet 2.0/Visual Basic 3.0 Compatibility Layer, the files CRW.EXE, PDBJET.DLL, PDCTJET.DLL, and PDIRJET.DLL are replaced by the Crystal Reports 2.0 versions because these are the versions that come with the Compatibility Layer.

The result is often a general protection (GP) fault because Crystal Reports version 3.0 expects to find either an updated copy of the 2.x version of these files or the 3.0 version of these files.

CAUSE

Visual Basic version 3.0 ships with the Crystal Reports version 2.0 PD*JET.DLL files, which are compatible with Microsoft Access version 1.1. The Compatibility Layer provides updates to these 2.0 versions of the PD*JET.DLL files to make them compatible with Microsoft Access version 2.0.

The Compatibility Layer replaces the 3.0 versions of the files with the 2.0 versions that are compatible with Microsoft Access version 2.0. This causes a problem because Crystal Reports version 3.0 only works with the 3.0 version of the PD*JET.DLL files (or a fixed 2.x version of these files, which can be acquired from Crystal Services). The result is often a GPF in Crystal Reports.

NOTE: The 3.0 versions of the PD*JET.DLL files that ship with Crystal Reports version 3.0 are only compatible with Microsoft Access version 1.1. This could also be a problem if you installed the Compatibility Layer and then installed Crystal Reports version 3.0. It would then not be able to reference an Microsoft Access version 2.0 database.

RESOLUTION

One alternative is to get the fixed 2.x versions of the PD*JET.DLL files (which are compatible with Microsoft Access version 2.0). Contact Crystal Services and ask for the file ACCESS20.ZIP.

However, it would be better to use the program called CRWACC20.EXE, which comes with the Compatibility Layer. This program can modify any version of the CRW.EXE, PDIRJET.DLL, PDCTJET.DLL, or PDBJET.DLL files so that they will work with Microsoft Access version 2.0.

You can correct any of the problems listed above by following these steps:

  1. Reload the files CRW.EXE, PDIRJET.DLL, PDCTJET.DLL, and PDBJET.DLL that come with Crystal Reports version 3.0 (the versions compatible with Microsoft Access version 1.1) onto your machine if they are not already there. This could be accomplished by reinstalling the Crystal Reports product.

  2. Run the CRWACC20.EXE program supplied with the Compatibility Layer.

    CRWACC20.EXE is an MS-DOS-based program that enables Crystal Reports for Visual Basic to work with the Microsoft Jet version 2.0 database engine. It modifies the following files:

        - CRW.EXE
        - PDBJET.DLL
        - PDIRJET.DLL
        - PDCTJET.DLL
    

    You must put the Crystal Reports modification program (CRWACC20.EXE) in the same directory as the files it modifies or give it a full path to the files (CRW.EXE, PDBJET.DLL, PDCTJET.DLL, and PDIRJET.DLL), which usually reside in different directories. You will find the CRWACC20.EXE program in the root of the Visual Basic directory.

    The CRWACC20.EXE program gives confirmation that it has modified the CRW.EXE file, but it does not give confirmation that it has found and modified the .DLL files.

    You can verify that all these the files were modified by looking at the date stamp, which lists the following dates for these files:

          CRW.EXE     - 3/16/94
          PDBJET.DLL  - 3/24/94
          PDIRJET.DLL - 3/24/94
          PDCTJET.DLL - 3/24/94
    
    
For information on obtaining the Compatibility Layer, please see the following article in the Microsoft Knowledge Base:

ARTICLE-ID: Q113951

TITLE     : How to Obtain & Distribute the Compatibility Layer

If you need information on contacting Crystal Services, please see the following article in the Microsoft Knowledge Base:

ARTICLE-ID: Q100368

TITLE     : How to Get Help w/ Crystal Reports -- International and U.S.

REFERENCES

For a complete list of Crystal Reports support, see the last three pages (PSS 1 through PSS 3) of the "Microsoft Visual Basic Professional Features" manual, book 2.

Crystal Report Writer and Crystal Reports are trademarks of Crystal Services, Vancouver, B.C., Canada.


Additional reference words: 3.00 Custom GPF
KBCategory: kb3rdparty kbinterop kbprb
KBSubCategory: IAPThird


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: December 3, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.