PRB: Component Download Fails for DCOM Projects

Last reviewed: May 14, 1997
Article ID: Q168429
The information in this article applies to:
  • Microsoft Visual Basic Control Creation and Enterprise Editions for Windows, version 5.0

SYMPTOMS

Component Download Fails for DCOM Projects when using Setup Wizard to create download files. If you have included a Remote Object in an ActiveX Document setup, you could see the following error on code download:

   "Internet Explorer is opening file of unknown type:
   <Name of Document>.VBD from"

CAUSE

The MySamp.cab download will not work if the Msracli.cab is located in a different folder than RemoteReg.cab.

RESOLUTION

MySamp should be the name of your project. The workaround for the download problem is below:

  1. Run the Setup Wizard from Visual Basic 5.0 and select "Add Remote." The Setup Wizard will create the download files for your MySamp project.

  2. Make sure Msracli.cab is located in the same folder as RemoteReg.cab. RemoteReg.cab is put in the download directory created by Setup Wizard. Msracli.cab is shipped on the Visual Basic 5.0 CD-ROM and is located in VB5/tools/cabinets/Msracli.cab.

  3. Modify the MySamp.inf file created by Setup Wizard:

    Code in MySamp.inf:

          [MSRACli.cab_Installer]
          file-win32-x86=http://activex.microsoft.com/controls/vb5/MSRACli.cab
          InfFile=MSRACli.inf
    

    Replace with:

          [MSRACli.cab_Installer]
          file-win32-x86=MSRACli.cab
          InfFile=MSRACli.inf
    

  4. Run Makecab.exe on MySamp.inf file. Makecab.exe is provided by Visual Basic 5.0 in the \vb5\setupkit\kitfil32\makecab.exe.

  5. Run the following line of code using the MySamp.ddf created by the Setup Wizard:

          makecab.exe /F MySamp.ddf
    

  6. This will create a MySamp.cab in the same directory as MySamp.ddf and MySamp.inf. Copy MySamp.cab to the correct directory and your download should work correctly.

STATUS

Microsoft is researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.


Keywords : kberrmsg vb5all VBKBInet VBKBSetup VBKBToolkit kbprb
Technology : kbole kbInetDev
Version : 5.0
Platform : WINDOWS
Issue type : kbprb


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: May 14, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.