The information in this article applies to:
- Microsoft Windows for Workgroups version 3.11
SYMPTOMS
When you share a folder on a Windows for Workgroups 3.11-based computer,
users on UNIX-based computers running the SMBCLIENT Samba network client
who connect to the shared folder may have access to the entire drive on
which the shared folder is located.
CAUSE
This problem can occur when all of the following conditions exist:
- You use the Vserver.386 file included with Windows for Workgroups 3.11.
- You use the TCP/IP network protocol.
- There are UNIX-based computers on the network.
RESOLUTION
To resolve this problem in Windows for Workgroups 3.11, follow these
steps:
- Download the Wfwvsrvr.exe file from one of the online services listed
below to an empty directory.
- In File Manager, double-click the Wfwvsrvr.exe file to expand the
Vserver.386 file it contains.
- Quit Windows for Workgroups.
- Copy the new Vserver.386 file to the Windows\System directory,
overwriting the existing version of the file.
- Restart your computer.
MORE INFORMATION
You can find Wfwvsrvr.EXE (size: 62665 bytes)
, a self-extracting file, on the following
services:
- Microsoft's World Wide Web Site on the Internet
On the www.microsoft.com home page, click the Support icon.
Click Knowledge Base, and select the product.
Enter kbfile Wfwvsrvr.EXE (size: 62665 bytes)
, and click GO!
Open the article, and click the button to download the file.
- Internet (anonymous FTP)
ftp ftp.microsoft.com
Change to the Softlib/Mslfiles folder.
Get Wfwvsrvr.EXE (size: 62665 bytes)
- Microsoft Download Service (MSDL)
Dial (425) 936-6735 to connect to MSDL
Download Wfwvsrvr.EXE (size: 62665 bytes)
For additional information about downloading, please see the following
article in the Microsoft Knowledge Base:
ARTICLE-ID: Q119591
TITLE : How to Obtain Microsoft Support Files from Online
Services