The information in this article applies to:
- Microsoft Windows operating system versions 3.0, 3.0a, 3.1, 3.11
- Microsoft Windows for Workgroups versions 3.1, 3.11
- Microsoft Windows 95
SYMPTOMS
You may receive one of the following error messages when you try to start
Windows or Windows for Workgroups:
- Cannot find KRNL386.EXE
- Cannot find KRNL286.EXE
- Cannot find KRNL.EXE (version 3.0 only)
- Cannot find or load required file KRNL386.EXE. The file was not found.
CAUSE
These messages indicate that Windows cannot find the kernel necessary
to run 386 enhanced, standard, or real mode (version 3.0 only). The kernel
provides system services such as memory and resource management.
This problem can also occur if the WIN386.EXE file is located in the
Windows folder. This file is run by WIN.COM, causing Windows to belive the
Windows folder is the Windows\System folder.
RESOLUTION
There are two methods for resolving this issue.
If Windows 95 Was Not Installed/Uninstalled
- Boot with clean AUTOEXEC.BAT and CONFIG.SYS files.
- Make sure that your Windows directory is on your MS-DOS path.
- Make sure that your path statement does not contain more than 128
characters.
- Make sure that the correct kernel file indicated in the warning
message actually exists in your Windows SYSTEM subdirectory. If you
are running a shared copy of Windows, make sure the file is in the
shared Windows directory.
- Add the Windows SYSTEM subdirectory to your MS-DOS path.
- Make sure your MS-DOS version is compatible with your computer.
- If you are using a shared installation of Windows on a network
server, make sure that your personal Windows directory and the
shared Windows directory are on your MS-DOS path and are listed
in that order.
- Ensure you don't have any upper memory block (UMB) conflicts. For more
information, query on the following words in the Microsoft Knowledge
Base:
troubleshooting and emm386.exe 4.45
- Rebuild the SYSTEM.INI file.
- As a last resort, reinstall Windows.
If Windows 95 Was Installed/Uninstalled
- Remove the WIN386.EXE file from the Windows folder. If there is no
WIN386.EXE file in the Windows\System folder, move the file from
the Windows folder to the Windows\System folder.
- Restart the computer.
- If these steps do not solve the problem, use the steps in the "If
Windows 95 Was Not Installed/Uninstalled" section.
|