Windows Screen Savers Corrupted by Pull-Down Menus

Last reviewed: September 12, 1995
Article ID: Q82434
The information in this article applies to:
  • Microsoft Windows operating system versions 3.1, 3.11

SYMPTOMS

After Dark and all other Microsoft Windows 3.0 screen savers are corrupted by pull-down menus when they are run in Windows version 3.1 or 3.11.

This problem does not occur with Windows 3.0.

CAUSE

This problem occurs because Windows 3.0 screen savers are not aware of topmost windows. Windows 3.1 menus are topmost. A Windows 3.1 compatible screen saver from the application vender is required to hide the pull-down menu.

In addition, Windows 3.1 and Windows 95 screen savers do not start if a pull-down menu is currently displayed (that is, when the menu is pulled down).

WORKAROUND

Use only Windows 3.1 compatible screen savers with Windows 3.1 or 3.11.

The product included here is manufactured by a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product's performance or reliability.


KBCategory: kb3rdparty
KBSubcategory: win31
Additional reference words: 3.10 3.1 afterdark 3.11


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: September 12, 1995
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.