Updated Drivers for File and Printer Sharing Security

Last reviewed: March 17, 1998
Article ID: Q128079
95 WINDOWS kbnetwork kbenv

The information in this article applies to:

  • Microsoft Windows 95

SYMPTOMS

When you use "File and printer sharing for Microsoft Networks" or "File and printer sharing for NetWare Networks" on a Windows 95-based computer, remote users may be able to gain access to your entire hard disk.

When you share a folder on a Windows 95-based computer, users on UNIX- based computers running the SMBCLIENT Samba network client who connect to the shared folder may be able to gain access to the entire drive on which the shared folder is located.

CAUSE

You may experience this problem with "File and printer sharing for NetWare Networks" or with "File and printer sharing for Microsoft Networks" when the following conditions are met.

File and Printer Sharing for NetWare Networks (Nwserver.vxd):

  • Your workstation is configured to share files and printers with "File and printer sharing for NetWare Networks."
  • Remote administration or the Microsoft Remote Registry service is enabled.

    NOTE: These options are not enabled by default.

File and Printer Sharing for Microsoft Networks (Vserver.vxd):
  • Your workstation is configured to share files and printers with "File and printer sharing for Microsoft Networks."
  • Your workstation connects to a LAN, Internet (SLIP or PPP account), or Dial-Up Networking connection that can be accessed by UNIX-based computers running the SMBCLIENT Samba network client.
  • The network administrator does not disable peer services using System Policies.

The SMBCLIENT Samba network client allows users to send illegal networking commands over the network. At this time, the Samba client is the only known SMBCLIENT that does not filter out such illegal commands. SMBCLIENT users do not automatically gain access to the Windows 95 drive; these users must know the exact steps to send these illegal commands.

RESOLUTION

To prevent these illegal commands from being run on a Windows 95 computer, Microsoft has released new versions of the Nwserver.vxd (4.00.951) and Vserver.vxd (4.00.952) files. These files are available in the Microsoft Windows 95 Service Pack 1 Update Setup.exe file.

For information about Microsoft Windows 95 Service Pack 1, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q142794
   TITLE     : Availability of Microsoft Windows 95 Service Pack 1

Installation

To install the updated files, follow these steps:

  1. Download the Setup.exe file from one of the online services listed below to an empty folder.

  2. In My Computer or Windows Explorer, double-click the Setup.exe file.

  3. Follow the instructions on the screen.

  4. After the installation process is finished, shut down and then restart your computer.

Running Setup.exe installs the Windows 95 Service Pack 1 Update, which automatically updates the Nwserver.vxd and Vserver.vxd files. After the update, illegal commands from SMBCLIENT will not be run on a Windows 95- based computer. The SMBCLIENT user will be able to gain access to only the Windows 95 shared folders that you designate.

You can find SETUP.EXE (size: 1264640 bytes) 
                       on the following services:

  • Microsoft's World Wide Web Site on the Internet

          On the www.microsoft.com home page, click the Support icon.
          Click Knowledge Base, and select the product.
    
          Enter kbfile SETUP.EXE (size: 1264640 bytes) 
                                , and click GO!
          Open the article, and click the button to download the file.
    
    
  • Internet (anonymous FTP)

          ftp ftp.microsoft.com
          Change to the Softlib/Mslfiles folder.
          Get SETUP.EXE (size: 1264640 bytes) 
    
  • Microsoft Download Service (MSDL)

          Dial (425) 936-6735 to connect to MSDL
          Download SETUP.EXE (size: 1264640 bytes) 
    

    For additional information about downloading, please see the following article in the Microsoft Knowledge Base:

       ARTICLE-ID: Q119591
       TITLE     : How to Obtain Microsoft Support Files from Online
                   Services
    

  • KBCategory: kbnetwork kbenv
    KBSubcategory: win95 msnets 3rdpartynet
    Additional reference words: 95 syspol msnWin95misc servicepack1
    Keywords : 3rdpartynet msnets win95 kbenv kbnetwork
    Version : 95
    Platform : WINDOWS


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    Last reviewed: March 17, 1998
    © 1998 Microsoft Corporation. All rights reserved. Terms of Use.