Problems Printing with Third-Party Device Drivers Installed

Last reviewed: October 2, 1997
Article ID: Q130588
The information in this article applies to:
  • Microsoft Windows 95

SYMPTOMS

You may experience either of the following symptoms:

  • When you print in Windows 95, you receive the following error message:

          Error writing to LPTx for Printer <xxxx>, there may be a problem
          with the Network or password is incorrect.
    

    In Device Manager, IRQ 7 may be listed as being used by an unknown device.

  • When you install a printer, you may not be able to print after you restart the computer.

CAUSE

These problems can be caused by third-party device drivers being loaded in the [386Enh] section of the System.ini file. The following device drivers are known to prevent programs from printing:

   Cis1284.386 from Canon Multipass
   Lex01.386 from Lexmark
   Lexsw2.386 from Lexmark
   Mpass.386 from Canon Multipass
   Okiport.386 from Okidata laser printers
   Sumovmi.386 from Panasonic KXP-6100 laser printers
   Vcpd.386
   Vecpd.386 from Netscape Navigator

RESOLUTION

To resolve the problem, follow these steps:

  1. Click the Start button, and then click Run.

  2. Type the following line in the Open box, and then click OK:

          system.ini
    

  3. Locate any of the following lines in the [386Enh] section of the file, and then remove or disable the lines:

        - DEVICE=<path>\Cis1284.386
        - DEVICE=<path>\Lex01.386
        - DEVICE=<path>\Okiport.386
        - DEVICE=<path>\Sumovmi.386
        - DEVICE=<path>\Vcpd.386
        - DEVICE=<path>\Vecpd.386
    

    NOTE: To disable a line, place a semicolon (;) at the beginning of the line.

  4. On the File menu, click Save.

  5. On the File menu, click Exit.

  6. Shut down and restart your computer.

If the problem persists, repeat steps 1-2. Disable any lines in the [386Enh] section that list a driver with a .386 extension, and then repeat steps 4-5.

MORE INFORMATION

Note that Canon has released new drivers for the Canon Multipass 1000. To obtain these drivers, contact Canon or visit the following Canon Web site:

   http://www.usa.canon.com

The third-party products discussed in this article are manufactured by vendors independent of Microsoft; we make no warranty, implied or otherwise, regarding these products' performance or reliability.


Additional query words: 95
Keywords : win95 windrvr kb3rdparty kberrmsg kbprint
Version : 95
Platform : WINDOWS


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Last reviewed: October 2, 1997
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