The information in this article applies to:
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, you should first make a backup copy of the
registry files (System.dat and User.dat). Both are hidden files in the
Windows folder.
SYMPTOMS
When you start Windows 95, you may receive one of the following error
messages:
- There is not enough memory to load the registry.
- Windows has encountered an error accessing the system registry.
You should restore the registry now and restart the computer.
If you ignore this error and shut down your system, you may lose data.
Restoring the registry replaces the faulty registry with a known
good backup copy. However, this backup copy may not contain all the
information recently added to your system.
NOTE: If you click the Restore From Backup And Restart button, you
receive the error message again as Windows 95 restarts.
CAUSE
These error messages may occur if the registry is damaged.
RESOLUTION
WARNING: Using Registry Editor incorrectly can cause serious problems
that may require you to reinstall Windows 95. Microsoft cannot guarantee
that problems resulting from the incorrect use of Registry Editor can be
solved. Use Registry Editor at your own risk.
NOTE: For information about how to edit the registry, view the Changing
Keys And Values online Help topic in Registry Editor (Regedit.exe). Note
that you should make a backup copy of the registry files (System.dat and
User.dat) before you edit the registry.
Perform the steps outlined in each method below (as needed) to restore a
damaged registry.
Using Real-Mode Registry Editor
Use Registry Editor in real mode to export, then import, the registry
file. To do so, follow these steps:
- Restart the computer. When you see the "Starting Windows 95" message,
press the F8 key, then choose "Safe mode command prompt only" from the
Startup menu.
- Type the following line to export the registry
regedit /l:<path1> /e <path2>system.txt
where <path1> is the path to the System.dat file and <path2> is the
path to the destination file. For example, if Windows 95 is installed
in the Windows folder on drive C, type the following line:
regedit /l:c:\windows\system.dat /e c:\system.txt
- Type the following lines, pressing ENTER after each line:
cd\windows
attrib -s -h -r system.dat
- Type the following line to rename the current registry file:
ren system.dat system.old
- Type the following line to import the System.dat portion of the
registry
regedit /l:<path1> /c <path2>system.txt
where <path1> is the path to the System.dat file and <path2> is the
path containing the file to import. For example, if Windows 95 is
installed in the Windows folder on drive C and you want to
import the System.txt file from the root folder of drive C,
type:
regedit /l:c:\windows\system.dat /c c:\system.txt
NOTE: If an "Unable to open registry" or "Error accessing the registry"
error message is displayed when you attempt to import the System.dat
portion of the registry, please see the following article in the
Microsoft Knowledge Base for more information about the error
message:
ARTICLE-ID: Q132064
TITLE : Regedit May Not Be Able to Import Registry with Large
Keys
- Restart Windows 95 normally.
If the error continues to occur, follow these steps:
- Restart the computer. When you see the "Starting Windows 95" message,
press the F8 key, and then choose "Safe mode command prompt only"
from the Startup menu.
- Type the following line to export the User.dat portion of the
registry
regedit /r:<path1> /e <path2>user.txt
where <path1> is the path to the User.dat file and <path2> is the
path to the destination file. For example, if Windows 95 is
installed in the Windows folder on drive C, type the following line:
regedit /r:c:\windows\user.dat /e c:\user.txt
- Type the following lines, pressing ENTER after each line:
cd\windows
attrib -s -h -r user.dat
- Type the following line to rename the User.dat file:
ren user.dat user.old
- Type the following line to import the User.dat portion of the
registry
regedit /r:<path1> /c <path2>user.txt
where <path1> is the path to the User.dat file and <path2> is the path
containing the file to import. For example, if Windows 95 is installed
in the Windows folder on drive C and you want to import the User.txt
file from the root folder of drive C, type:
regedit /r:c:\windows\user.dat /c c:\user.txt
NOTE: If an "Unable to open registry" or "Error accessing the
registry" error message is displayed when you attempt to import the
User.dat portion of the registry, please see the following article
in the Microsoft Knowledge Base:
ARTICLE-ID: Q132064
TITLE : Regedit May Not Be Able to Import Registry with Large
Keys
- Restart Windows 95 normally.
For additional information about using Registry Editor in real mode,
please see the following article in the Microsoft Knowledge Base:
ARTICLE-ID: Q131352
TITLE : Using Registry Editor in Real Mode
If the error continues to occur after you follow the steps in this
section, please see the next section.
Using System.da0
Restore the registry to its state when you last successfully started
Windows 95. To do so, follow these steps:
- Restart the computer. When you see the "Starting Windows 95" message,
press the F8 key, then choose "Safe mode command prompt only" from the
Startup menu.
- Type the following command to move to the Windows folder
cd \<windows>
where <windows> is the Windows 95 folder. For example, if Windows
95 is installed in the Windows folder, type the following line:
cd \windows
- Type the following line:
attrib -s -h -r system.dat
- Type the following line:
ren system.dat system.bad
- Restart your computer. Windows 95 uses the System.da0 file
when it cannot find the System.dat file. If this file works,
Windows 95 renames it to System.dat.
If the error continues to occur after you follow the steps in this
section, please see the next section.
Using System.1st
Restore the registry to its state when you first started Windows 95
successfully. To do so, follow these steps:
- Restart the computer. When you see the "Starting Windows 95" message,
press the F8 key, then choose "Safe mode command prompt only" from the
Startup menu.
- Type the following command to move to the Windows folder
cd \<windows>
where <windows> is the Windows 95 folder. For example, if
Windows 95 is installed in the Windows folder, type the following
line:
cd \windows
- Type the following line:
attrib -s -h -r system.dat
- Type the following line:
ren system.dat system.xxx
- Type the following line:
cd \
- Type the following line:
attrib -s -h -r system.1st
- Type the following line
copy system.1st c:\<windows>\system.dat
where <windows> is your Windows 95 folder.
- Type the following line:
attrib +s +h +r system.1st
- Restart your computer.
If the error continues to occur after you follow the steps in this
section, please see the next section.
NOTE: You may find that your TrueType fonts are missing from the Fonts
folder or in programs after you follow the above steps. If this is the
case, use the resolution listed in the following article in the Microsoft
Knowledge Base:
ARTICLE-ID: Q133732
TITLE : Missing TrueType Fonts in Fonts Folder or Programs
Reinstalling Windows 95
Re-create the registry files by reinstalling Windows 95.
To do this, perform the following steps.
NOTE: If you cannot access the CD-ROM drive from the command prompt,
consult the CD-ROM drive's documentation or manufacturer for assistance
with loading the real-mode drivers for the CD-ROM drive.
- Restart the computer. When you see the "Starting Windows 95" message,
press the F8 key, then choose Command Prompt Only from the Startup
menu.
- Type the following line and then press ENTER to remove all user
profiles:
deltree c:\windows\profiles
- Rename the existing registry files by typing the following lines.
Press ENTER after each line:
cd \windows
attrib -s -h -r system.dat
ren system.dat system.xxx
attrib -s -h -r user.dat
ren user.dat user.xxx
attrib -s -h -r system.da0
ren system.da0 system.yyy
attrib -s -h -r user.da0
ren user.da0 user.yyy
cd \
attrib -s -h -r system.1st
ren system.1st system.zzz
- Run Windows 95 Setup.