Err Msg: Drive C Contains Errors That Must Be Corrected...

Last reviewed: February 27, 1996
Article ID: Q132883
The information in this article applies to:
  • Microsoft Windows 95
  • Microsoft Plus! for Windows 95

SYMPTOMS

You may experience one of the following problems while using DriveSpace:

  • When you upgrade a compressed drive from DriveSpace to DriveSpace 3, you may receive the following error message:

          You cannot upgrade drive X because it contains errors. To upgrade
          this drive, first run ScanDisk on it, and then try again to upgrade
          it.
    

          ID Number: DRVSPACE 424
    

    -or-

  • When you compress an existing uncompressed drive, you may receive the following error message:

          Drive X contains errors that must be corrected before the drive can
          be compressed. To correct them run ScanDisk.
    

          ID Number: DRVSPACE 306
    

    -or-

  • When you uncompress a compressed drive, you may receive the following error message:

          Drive X contains errors that must be corrected before the drive can
          be uncompressed. To correct them, run ScanDisk.
    

          ID Number: DRVSPACE 307
    

    -or-

  • When you create a new empty compressed drive, you may receive the following error message:

          Drive C contains errors that must be corrected before the drive can
          be used to create a new compressed drive. To correct them run
          ScanDisk.
    

          ID Number: DRVSPACE 308
    

CAUSE

These errors can occur if the drive contains a folder with a path that contains more than 66 characters. For example, the following path contains more than 66 characters:

   C:\Windows\Profiles\<username>\Startm~1\Programs\Winapp\Winword\Setup

RESOLUTION

To work around this problem, follow these steps:

  1. Start ScanDisk. Click the Automatically Fix Errors check box to clear it, and then begin checking the drive.

  2. When you receive the error message

          The <path> folder could not be opened in MS-DOS mode because
          its complete short name was longer than 66 characters.
    

    make a note of the path that is longer than 66 characters, and then click Ignore. If you receive more than one such message, note each path.

  3. After ScanDisk is finished, move each folder whose path contains more than 66 characters to another location with a shorter path.

  4. Perform the DriveSpace operation you want.

  5. After the DriveSpace operation is finished, move each folder that you moved in step 3 back to its original location.

MORE INFORMATION

This is not a limitation in Windows 95 or DriveSpace. Windows 95 allows paths with more than 66 characters. However, MS-DOS does not allow these long paths. When you use the Automatically Fix Errors option in ScanDisk, a path that is longer than 66 characters is considered valid to Windows 95 and invalid to MS-DOS.

ScanDisk does not try to fix the path because the path is valid to Windows 95. However, when DriveSpace runs in mini-Windows mode, a folder with a path longer than 66 characters cannot be processed correctly.

This situation may occur when you are using user profiles because of the long directory structure that is created. User profiles can store the entire Start Menu directory structure, creating paths longer than 66 characters.


KBCategory: kbtool kberrmsg
KBSubcategory: win95 winplus drvspace scandskw
Additional reference words: 95


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Last reviewed: February 27, 1996
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