The information in this article applies to:
SYMPTOMS
After you upgrade to Windows 95, you may not be able to print to your
Hewlett-Packard (HP) DeskJet printer. You may experience any of the
following symptoms:
CAUSE
The Windows 3.1 drivers for the HP DeskJet printer were not successfully
upgraded to the Windows 95 versions.
RESOLUTION
To resolve this problem, follow these steps:
- Double-click the Printers icon in Control Panel.
- Use the right mouse button to click the HP DeskJet printer, and then
click Delete on the menu that appears.
- If there is more than one HP DeskJet printer in the Printers folder,
repeat step 2 for each HP DeskJet printer.
- Locate and remove the following files in the Windows folder:
Deskjet.ini
Deskjetc.ini
NOTE: Your computer may have only one of these files, or both.
- Locate and remove the following files in the Windows\System folder.
To avoid deleting files that may be crucial to other HP components,
delete only these files:
DESKJETC.DRV
HPDSKJET.DRV
HPSETUP3.DLL
HPV1284.DLL
HPV500.HPC
HPV500C.HPC
HPV510.HPC
HPV520.HPC
HPV540_A.HPC
HPV540_B.HPC
HPV550C.HPC
HPV560C.HPC
HPV660C.HPC
HPVBG.EXE
HPVCM.HPM
HPVCNFIG.EXE
HPVDOS.DLL
HPVDSM.EXE
HPVEXT24.DLL
HPVHT.DLL
HPVMLC.DLL
HPVMLCH.EXE
HPVMON.DLL
HPVPML.DLL
HPVQP.DLL
HPVRES.DLL
HPVTTPCL.DLL
HPVUI.DLL
HPVWCPS.DLL
HPVWIN.DLL
SCONFIG.DLL
TBKBASE.DLL
TBKCOMP.DLL
TBKNET.EXE
TBKUTIL.DLL
TBOOK.EXE
- Rename all the Oem<n>.inf files in the Windows\Inf folder, where <n>
is an incremental number starting at 0.
NOTE: Do not use the oem*.inf wildcard to rename files. Doing so may
cause the wrong files to be renamed. For information about rebuilding
the driver information database, please see the following article in
the Microsoft Knowledge Base:
ARTICLE-ID: Q137377
TITLE: Removing Windows 3.1 Drivers from Wizard Hardware Lists
- If the HP DeskJet Status Monitor is in the Startup group, remove it.
To do so, follow these steps:
a. Use the right mouse button to click the taskbar, and then click
Properties on the menu that appears.
b. Click the Start Menu Programs tab, and then click Remove.
c. Double-click the Startup branch to expand it.
d. Click the HP DeskJet Status Monitor shortcut, and then click
Remove.
e. Click Close.
- Restart your computer.
- Use the Add Printer Wizard to reinstall the HP DeskJet printer.
NOTE: Make sure to select the DeskJet driver included with Windows 95,
not the Windows 3.x HP printer driver. If the new Deskjet Printer does
not show up in the Add New Hardware List, remove the Drvidx.bin and
Drvdata.bin files from the Windows\Inf folder. This will cause the Add
New Hardware Device Database list to be updated with the new printer.
MORE INFORMATION
For additional information about troubleshooting printing problems in
Windows 95, please see the following article in the Microsoft Knowledge
Base:
ARTICLE-ID: Q128345
TITLE: Troubleshooting Printing Problems in Windows 95
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