Err Msg: Windows Could Not Find a Backup Program

Last reviewed: May 8, 1996
Article ID: Q140359
The information in this article applies to:
  • Microsoft Windows 95

IMPORTANT: This article contains information about editing the registry. Before you edit the registry, you should first make a backup copy of the registry files (System.dat and User.dat). Both are hidden files in the Windows folder.

SYMPTOMS

When you use DriveSpace to compress an existing drive, you are given the option to back up files before you compress the drive. When you click Back Up Files, you may receive the following error message:

   Windows could not find a backup program on your system. To install
   Microsoft Backup now, click Install Now, double-click the Disk Tools
   component and then follow the instructions on your screen. To
   continue without installing or running Backup, choose Continue.

The problem persists even if you click Install Now to install Microsoft Backup.

CAUSE

This error can occur if there is an invalid Backuppath entry in the registry. If the Backuppath entry is invalid, reinstalling Backup does not solve the problem.

RESOLUTION

NOTE: For information about how to edit the registry, view the Changing Keys And Values online Help topic in Registry Editor (Regedit.exe). Note that you should make a backup copy of the registry files (System.dat and User.dat) before you edit the registry.

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows 95. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

To correct this problem, locate the following key in the registry:

   HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\
   Explorer\MyComputer\Backuppath

Change the value for the (Default) value to a valid path for Backup.exe.


KBCategory: kbtool kberrmsg
KBSubcategory: win95 mwbackup
Additional reference words: 95


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: May 8, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.