Compression Agent Detects Errors Even After Running ScanDisk

Last reviewed: August 13, 1997
Article ID: Q140431
The information in this article applies to:
  • Microsoft Windows 95
  • Microsoft Plus! for Windows 95

SYMPTOMS

When you try to recompress a disk with Compression Agent, you may receive one of the following error messages:

  • Compression Agent cannot recompress this drive because it contains errors that must first be repaired. Click Help, carry out the instructions for repairing the errors, and then try again.
  • Compression Agent could not finish recompressing the drive because there was an error. ID No: CMPAGENT103

The same error message may occur again even if you run ScanDisk and correct the errors on the disk before running Compression Agent again.

CAUSE

This behavior can occur if the compressed drive contains unreliable clusters that ScanDisk cannot detect.

RESOLUTION

Configure ScanDisk to detect disk timeouts while performing a surface scan, and then run ScanDisk from a command prompt. To do so, follow these steps:

  1. Click the Start button, click Shut Down, click the "Restart the computer in MS-DOS mode" option, and then click Yes.

  2. Type the following line, and then press ENTER:

          edit c:\windows\command\scandisk.ini
    

  3. Add the following line to the [Environment] section of the file:

          ScanTimeOut=On
    

  4. Save the Scandisk.ini file, and then exit the editor.

  5. Type the following line and then press ENTER to run ScanDisk:

          scandisk
    

    Run a surface scan when ScanDisk prompts you to do so.

  6. Repair any errors that ScanDisk finds.

  7. When ScanDisk is finished, type "exit" (without quotation marks) and then press ENTER.

  8. Run Compression Agent again.

MORE INFORMATION

The "ScanTimeOut=On" entry causes ScanDisk to detect disk timeouts while performing a surface scan. This allows ScanDisk to detect marginal clusters that are not reliable enough to store data. These clusters are detected by Compression Agent when you attempt to recompress your files, but they are not normally detected by ScanDisk.

Additional qeury words: 95

Keywords          : win95 winplus kberrmsg kbtool
Version           : 95
Platform          : WINDOWS


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: August 13, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.