No Windows or Network Logon Dialog Box at Startup

Last reviewed: December 15, 1997
Article ID: Q141858
The information in this article applies to:
  • Microsoft Windows 95

IMPORTANT: This article contains information about editing the registry. Before you edit the registry, you should first make a backup copy of the registry files (System.dat and User.dat). Both are hidden files in the Windows folder.

SYMPTOMS

When you start Windows 95, you may not receive a Windows or a Network Logon dialog box, or you may receive one of the following error messages:

  • No network provider accepted the given network path.
  • The operation being requested was not performed because the user has not logged on to the network. The specified service does not exist.

Or, the Change Passwords tab may be missing from the Passwords Properties dialog box. Note that this symptom occurs only if the second cause listed below is in effect.

CAUSE

This behavior can occur if any of the following conditions are true:

  • The Primary Network Logon field is not set correctly.
  • The following entry appears in the HKEY_LOCAL_MACHINE\Software\ Microsoft\Windows\CurrentVersion\Network\Real Mode Net registry key

          AutoLogon=<x>
    

    where <x> is a number.

  • You are logging on to a Novell NetWare network and the server you log on to is running multiple frame types.
  • You are logging on to a Microsoft or NetWare network and you have cached your network password.
  • The network adapter is improperly configured.

RESOLUTION

Use the following troubleshooting steps to resolve the problem. Make sure to restart Windows 95 after each step.

Warnings

You can edit the registry using System Policy Editor (Poledit.exe) or Registry Editor (Regedit.exe). Check with your network administrator before you make any changes to the registry.

For information about how to edit the registry, view the Changing Keys And Values online Help topic in Registry Editor (Regedit.exe). Note that you should make a backup copy of the registry files (System.dat and User.dat) before you edit the registry.

Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows 95. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

System Policy Editor (Poledit.exe) is available in the Admin\Apptools\ Poledit folder on the Windows 95 CD-ROM. Use the Add/Remove Programs tool in Control Panel to install System Policy Editor.

NOTE: System Policy Editor is not included in the floppy disk version of Windows 95. You can download Policy.exe, a self-extracting executable file containing Poledit.exe, from online services. Please see the following article in the Microsoft Knowledge Base for information about downloading Policy.exe:

   ARTICLE-ID: Q135315
   TITLE     : CD-ROM Extras for Microsoft Windows 95 Upgrade

Troubleshooting Steps

  1. In Control Panel, double-click Network. Click the appropriate setting in the Primary Network Logon box, and then click OK.

  2. Delete the following entry in the HKEY_LOCAL_MACHINE\Software\ Microsoft\Windows\CurrentVersion\Network\Real Mode Net registry key:

          AutoLogon=<x>
    

  3. In Control Panel, double-click Network. Double-click the IPX/SPX- compatible protocol, click the Advanced tab, click Frame Type, change the value from Auto to the specific frame type running on the server you log in to, click OK, and then click OK again. If you do not know which frame type is running on the server you log in to, contact your network administrator.

  4. Repeat step 3 as necessary, trying each frame type, to determine if selecting one of the frame types causes a Network Logon dialog box to appear at startup.

  5. Disable the Automatic NetWare Login option with System Policy Editor (as described on page 515 of the Microsoft Windows 95 Resource Kit), or with Registry Editor by adding the following DWORD value:

          HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\
          NetworkProvider\DisableDefaultPasswords = 1
    

For information about troubleshooting problems related to enabling the Maximum Sockets or Maximum Connections settings, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q142489
   TITLE     : Problems After Modifying Maximum Connections or Sockets
               Value

MORE INFORMATION

If you use the right mouse button to click a NetWare server in Network Neighborhood and then click Attach As on the menu that appears, you have the option to save (or cache) your password. If you save the password, it is stored in your password cache file. If the Primary Network Logon field is not set to Client For NetWare Networks, you are not prompted to log on to your preferred server.

For additional information, see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q127933
   TITLE     : Err Msg: No Network Provider Accepted the Given Network
               Path


Additional query words: 95 dun dial-up networking
Keywords : msnets win95 kbnetwork kbtshoot
Version : 95
Platform : WINDOWS


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Last reviewed: December 15, 1997
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