OLE Problems Using Microsoft Service for NDS

Last reviewed: November 26, 1997
Article ID: Q142532
The information in this article applies to:
  • Microsoft Windows 95

SYMPTOMS

You may experience any of the following symptoms:

  • When you try to insert an object from a network location, you may receive an error message similar to one of the following messages:

        - Word cannot obtain the data for the <drive>:\<path>\<filename.ext>
          link.
    

        - Cannot insert object.
    

        - The server application, source file, or item cannot be found.  You
          should reinstall the server application.
    
  • When you attempt to set the default directory for Microsoft Word documents to a location on a mapped network drive, you may receive the following error message:

          The directory is not valid.
    
  • When you attempt to use Microsoft Backup to perform a backup to a network drive mapped using the Microsoft Service for NetWare Directory Services (MSNDS), you may receive the following error message:

          Microsoft backup could not create a file on the device you want to 
          back up to. Make sure you specify a valid name for the device, and 
          that you have the necessary network access rights, and then try 
          again. For more information, contact your network administrator.
    

    If you attempt to connect to the share using Network Neighborhood, you are able to do so.

CAUSE

These errors can occur when the object you are attempting to insert exists on a network drive mapped using the Microsoft Service for NetWare Directory Services (MSNDS).

RESOLUTION

To work around this problem, instead of using an MSNDS-mapped drive, use the Browse button to find the network location of the object in Network Neighborhood. This uses the Universal Naming Convention (UNC) path for the object, rather than mapping a drive letter to the network location where the object exists.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 95. An update to address this problem is now available, but is not fully regression tested and should be applied only to computers experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft does not recommend implementing this update at this time. Contact Microsoft Technical Support for additional information about the availability of this update.


Additional query words: 95 word95 word7 mail merge helper datasource mmh
Keywords : 3rdpartynet win95 kberrmsg kbnetwork kbole
Version : 95
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: November 26, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.