The information in this article applies to:
SYMPTOMS
You may receive one of the following error messages and Windows 95 may
stop responding (hang) or run with limited functionality:
- RUNDLL32.EXE has caused an error in COMMCTRL.DLL
- The COMCTL32.DLL file cannot start
CAUSE
These errors can occur if the Commctrl.dll file is missing or damaged.
RESOLUTION
To resolve this problem, follow these steps:
- Restart your computer. When you see the "Starting Windows 95" message,
press the F8 key, and then choose Command Prompt Only from the
Startup menu.
- Type the following commands, pressing ENTER after each line:
cd \windows\system
ren commctrl.dll commctrl.old
- Use the Extract tool to extract the Kommctrl.dll file from the
Precopy1.cab file on disk 1 of your Windows 95 disks or in the
Win95 folder on the Windows 95 CD-ROM to the Windows\System
folder.
For information about using the Extract tool, please see the following
article in the Microsoft Knowledge Base:
ARTICLE-ID: Q129605
TITLE : How to Extract Original Compressed Windows Files
- Type the following lines, pressing ENTER after each line:
cd \windows\system
ren kommctrl.dll commctrl.dll
- Type the following line, and then press ENTER:
copy commctrl.dll c:\windows\sysbckup
When you are prompted to overwrite the existing file, press Y.
- Restart your computer.
MORE INFORMATION
Note that the Precopy1.cab file also contains a Commctrl.dll file. This
file is used only by Setup. If you extract this file instead of the
Kommctrl.dll file, Windows 95 will not run.