Windows 95 Logon Script Is Not Processed

Last reviewed: October 31, 1996
Article ID: Q150589
The information in this article applies to:
  • Microsoft Windows 95

SYMPTOMS

A Windows 95 workstation logging on to a Microsoft Windows NT primary domain controller (PDC) may not process the centralized logon script batch file.

CAUSE

This problem can occur if multiple Windows 95 workstations try to run a logon script file (for example, the Winlogon.bat file) located on a single Windows NT PDC at the same time. The first time a Windows 95 workstation access the logon script file, it does so in Read/Share/Exclusive mode. All subsequent accesses to the file are done in Read/Share/Deny None mode.

The exclusive requests fail when another workstation has the file open in Read/Share/Deny None mode.

STATUS

Microsoft has confirmed this to be a problem in Windows 95. We are researching this problem and will post new information here as it becomes available.


KBCategory: kbnetwork
KBSubcategory: win95
Additional reference words: 95


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: October 31, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.