Errors Accessing Hard Disk with Spin-Down Enabled

Last reviewed: November 26, 1997
Article ID: Q154436
The information in this article applies to:
  • Microsoft Windows 95
  • Microsoft Windows 95 OEM Service Release versions 2, 2.1

SYMPTOMS

When some IDE hard disks are configured to spin down during idle time to conserve power, you may experience the following symptoms when you access the hard disk after it has spun down:

  • Incorrect data is read from or written to the drive.
  • You receive general protection (GP) fault error messages.

CAUSE

These symptoms can occur if the hard disk requires more than 7.5 seconds to spin up. When this occurs, an error in the Windows 95 driver results in incorrect data being read from the drive, which can result in GP faults.

RESOLUTION

You can work around this problem by disabling hard disk spin-down on the Disk Drives tab using the Power tool in Control Panel.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 95 and OEM Service Release 2 (OSR2). An update to address this problem is now available, but is not fully regression tested and should be applied only to computers experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft does not recommend implementing this update at this time.

This issue is resolved by the following updated file for Windows 95 and OSR2:

   Esdi_506.pdr version 4.00.1113 (dated 12/6/96) and later

For Windows 95, the following additional file is also required:

   Voltrack.vxd version 4.00.954 (dated 3/6/96) and later

   NOTE: This file is not required if you are running OSR2.

To install this update, follow these steps:

  1. Download the Remideup.exe file from the online service listed below to an empty folder.

  2. In My Computer or Windows Explorer, double-click the Remideup.exe file you downloaded in step 1.

  3. Follow the instructions on the screen.

The following file(s) are available for download from the Microsoft Software Library:

 ~ remideup.exe (size: 147096 bytes) 

For more information about downloading files from the Microsoft Software Library, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q119591
   TITLE     : How to Obtain Microsoft Support Files from Online Services

The following files are installed by Remideup.exe:

   File name     Version    Date/Time       Size    Destination folder
   ------------------------------------------------------------------------
   Esdi_506.pdr  4.00.1116  8/25/97 11:16a  24,426  Windows\System\Iosubsys
   Voltrack.vxd  4.00.954   3/6/96 9:54a    18,518  Windows\System\Iosubsys

NOTE: The Voltrack.vxd file is installed on Windows 95 computers only. This file is not installed on computers running OSR2.

MORE INFORMATION

For additional information about issues resolved by updates to this component, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q171353
   TITLE     : Computer with Ultra DMA IDE Controller May Hang

   ARTICLE-ID: Q161642
   TITLE     : Auto Insert Notification May Prevent Automatic Suspend

   ARTICLE-ID: Q160800
   TITLE     : "Fatal Exception Error" with Iomega IDE Zip Drives

   ARTICLE-ID: Q154976
   TITLE     : Error Message Running Jet Database Engine Stress Test

   ARTICLE-ID: Q154435
   TITLE     : Windows 95 IDE Support for SMART, DMA, and ATAPI Tape
               Drives

   ARTICLE-ID: Q153471
   TITLE     : Problems with Removable IDE Drives in Windows 95


Additional query words: 95 gpf
Keywords : osr2 win95 windrvr kbhw kbpolicy kbfixlist
Version : 95
Platform : WINDOWS


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Last reviewed: November 26, 1997
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