Error Changing Password with Multiple Network User Names

Last reviewed: April 23, 1997
Article ID: Q154809
The information in this article applies to:
  • Microsoft Windows 95

SYMPTOMS

When you try to change a network password using the Passwords tool in Control Panel, you may receive an error message similar to one of the following messages:

  • Unable to change the password for Microsoft Networking because of the following error: The username cannot be found
  • Unable to change the password for Microsoft Networking because of the following error: Incorrect password

CAUSE

This error can occur if you have multiple network clients installed and you are logged on using a different user name for each client. For example, this error occurs if you use one user name for the Client for Microsoft Networks and another user name for the Client for NetWare networks.

RESOLUTION

To work around this behavior, use either of the following methods:

  • Use the same user name for all network clients.
  • Use the appropriate command-line tool to change your password. For a Microsoft Network password, use the NET PASSWORD command. For a Novell NetWare Network password, use the SETPASS command.

    The NET PASSWORD command works in MS-DOS mode. To make the NET PASSWORD command work in an MS-DOS session within Windows 95, follow these steps:

    1. Use the right mouse button to click the MS-DOS Prompt icon, and then

          click Properties.
    

    2. Click the Program tab, and then click Advanced.

    3. Click the "Prevent MS-DOS-based programs from detecting Windows"

          check box to select it.
    

    4. Click OK.

    5. Restart the computer. If you do not follow these steps and you try to use the NET PASSWORD command in an MS-DOS session within Windows 95, you receive the following error message:

          Error 3547: You cannot do this from within an MS-DOS window
    

STATUS

Microsoft is researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

Windows 95 does not provide for changing passwords using the Passwords tool in Control Panel when multiple user names are used.

For additional information about issues with multiple network user names, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q130797
   TITLE     : Cannot Specify Different Default Logon Name for Second
               Client


Additional query words: 95
Keywords : kberrmsg kbnetwork win95
Version : 95
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: April 23, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.