Error Message Running Jet Database Engine Stress Test

Last reviewed: November 26, 1997
Article ID: Q154976
The information in this article applies to:
  • Microsoft Windows 95

SYMPTOMS

When you are running a program that causes a large number of writes to occur very rapidly to an IDE drive, you may receive the following error message on a blue screen:

   Disk Write Error
   Unable to write to disk in drive <x>:
   Data or files may be lost

You may be able to recover from this error by pressing a key to remove the error message and retry the write. The operation typically continues, although additional errors may occur until the operation is finished.

CAUSE

If a program generates a large number of disk writes very quickly, a timing problem involving the IDE disk driver and the cache may occur, resulting in the error message.

This symptom has been reported to occur with a hard disk stress test using the Microsoft Jet database engine that is included with the current versions of Microsoft Visual Basic, Microsoft Office, and Microsoft Access.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 95. An update to address this problem is now available, but is not fully regression tested and should be applied only to computers experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft does not recommend implementing this update at this time.

This issue is resolved by the following updated files for Windows 95:

   Esdi_506.pdr version 4.00.956 (dated 5/14/96) and later
   Voltrack.vxd version 4.00.954 (dated 3/6/96) and later

To install this update, follow these steps:

  1. Download the Remideup.exe file from the online service listed below to an empty folder.

  2. In My Computer or Windows Explorer, double-click the Remideup.exe file you downloaded in step 1.

  3. Follow the instructions on the screen.

The following file(s) are available for download from the Microsoft Software Library:

 ~ remideup.exe (size: 147096 bytes) 

For more information about downloading files from the Microsoft Software Library, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q119591
   TITLE     : How to Obtain Microsoft Support Files from Online Services

The following files are installed by Remideup.exe:

   File name     Version    Date/Time       Size    Destination folder
   ------------------------------------------------------------------------
   Esdi_506.pdr  4.00.1116  8/25/97 11:16a  24,426  Windows\System\Iosubsys
   Voltrack.vxd  4.00.954   3/6/96 9:54a    18,518  Windows\System\Iosubsys

NOTE: The Voltrack.vxd file is installed on Windows 95 computers only. This file is not installed on computers running OSR2.

MORE INFORMATION

For additional information about issues resolved by updates to this component, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q171353
   TITLE     : Computer with Ultra DMA IDE Controller May Hang

   ARTICLE-ID: Q161642
   TITLE     : Auto Insert Notification May Prevent Automatic Suspend

   ARTICLE-ID: Q160800
   TITLE     : "Fatal Exception Error" with Iomega IDE Zip Drives

   ARTICLE-ID: Q154436
   TITLE     : Errors Accessing Hard Disk with Spin-Down Enabled

   ARTICLE-ID: Q154435
   TITLE     : Windows 95 IDE Support for SMART, DMA, and ATAPI Tape
               Drives

   ARTICLE-ID: Q153471
   TITLE     : Problems with Removable IDE Drives in Windows 95


Additional query words: 95 vb script
Keywords : win95 kberrmsg kbhw kbpolicy kbfixlist
Version : 95
Platform : WINDOWS


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Last reviewed: November 26, 1997
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