Error Message: ScanDisk Cannot Check Drive

Last reviewed: March 20, 1998
Article ID: Q154998
The information in this article applies to:
  • Microsoft Windows 95
  • Microsoft Windows 95 OEM Service Release 2

SYMPTOMS

When you try to run ScanDisk, you may receive one of the following error messages:

  • ScanDisk cannot examine drive <drive letter>:

    This version of Microsoft ScanDisk will work only with MS-DOS versions 5.0 and later.

  • ScanDisk cannot check this drive now because the disk is not properly formatted, or a program such as a disk utility has locked it. Format the disk or wait for the utility to finish, and then restart ScanDisk.

CAUSE

This symptom can occur for either of the following reasons:

  • You run a previously released version of ScanDisk with OEM Service Release 2 (OSR2). For example, this could occur if you run ScanDisk from an Emergency Boot Disk created using an earlier version of Windows 95.
  • You run an OSR2 version of ScanDisk in Windows 95. For example, this could occur if you run ScanDisk from an Emergency Boot Disk created using OSR2 on a computer running Windows 95.

RESOLUTION

To resolve this issue, use the appropriate method:

Running Windows 95 OSR2

The following files are required by the Windows 95 OSR2 version of ScanDisk:

  • Windows\Scandskw.exe 4,896 bytes
  • Windows\System\Dskmaint.dll 214,048 bytes
  • Windows\Command\Scandisk.exe 142,353 bytes

Restore the appropriate files from the Windows 95 OSR2 CD-ROM using the following steps:

  1. Start an MS-DOS prompt in Windows 95.

  2. Type "cd windows" and then press ENTER.

  3. Type the following lines, pressing ENTER after each line:

          ren scandskw.exe *.bak
          ren system\dskmaint.dll *.bak
          ren command\scandisk.exe *.bak
    

  4. Insert the Microsoft Windows 95 OSR2 CD-ROM in the CD-ROM drive.

  5. Type the following lines, pressing ENTER after each line

          extract <drive>:\win95\win95_16.cab scandskw.exe /L %windir%
          extract <drive>:\win95\precopy2.cab dskmaint.dll /L %windir%\system
          copy <drive>:\win95\scandisk.exe %windir%\command
    

    where <drive> is the drive letter of the CD-ROM drive.

Running Windows 95

The following files are required by the Windows 95 version of ScanDisk:

  • Windows\Scandskw.exe 4,608 bytes
  • Windows\System\Dskmaint.dll 189,456 bytes
  • Windows\Command\Scandisk.exe 134,738 bytes

Restore the appropriate files from the Windows 95 CD-ROM or floppy disks using the following steps:

  1. Start an MS-DOS prompt in Windows 95.

  2. Type "cd windows" and then press ENTER.

  3. Type the following lines, pressing ENTER after each line:

          ren scandskw.exe *.bak
          ren system\dskmaint.dll *.bak
          ren command\scandisk.exe *.bak
    

Extract the files using the appropriate method:

Windows 95 CD-ROM:

  1. Insert the Microsoft Windows 95 CD-ROM in the CD-ROM drive.

  2. Type the following lines, pressing ENTER after each line

          extract <drive>:\win95\win95_09.cab scandskw.exe /l %windir%
          extract <drive>:\win95\precopy2.cab dskmaint.dll /l %windir%\system
          copy <drive>:\win95\scandisk.exe %windir%\command
    

    where <drive> is the drive letter of the CD-ROM drive.

  3. Type "exit" (without quotation marks), and then press ENTER to return to windows.

Windows 95 Floppy disks:

  1. Type "cd\" (without quotation marks), and then press ENTER.

  2. Insert disk 9 of the Windows 95 disks into the floppy disk drive.

  3. Type the following line at the command prompt, and then press ENTER

          extract /a <drive>:\win95_09.cab scandskw.exe /l %windir%
    

    where <drive> is the drive letter assigned to the floppy disk drive in which the Windows 95 floppy disk is located.

  4. Insert disk 2 of the Windows 95 disks into the floppy disk drive.

  5. Type the following line at the command prompt, and then press ENTER:

          extract /a <drive>:\ precopy2.cab dskmaint.dll /l %windir%\system
    

  6. Insert disk 1 of the Windows 95 disks into the floppy disk drive.

  7. Type the following line at the command prompt, and then press ENTER:

          copy <drive>:\scandisk.exe %windir%\command
    

  8. Type "exit" (without quotation marks), and then press ENTER to return to windows.

MORE INFORMATION

For more information about using the Extract tool, click the Start button, point to Programs, click MS-DOS prompt, type "extract" (without quotation marks), and then press ENTER. Or, see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q129605
   TITLE     : How to Extract Original Compressed Windows Files

For more information about Windows 95 OSR2, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q155003
   TITLE     : Description of Windows 95 OEM Service Release 2


Additional query words: 95
Keywords : osr2 win95 kberrmsg kbtool
Version : 95
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 20, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.