Removed Device Not Detected by Add New Hardware Wizard

Last reviewed: November 7, 1996
Article ID: Q158922
The information in this article applies to:
  • Microsoft Windows 95
  • Microsoft Windows 95 OEM Service Release versions 2, 2.1

SYMPTOMS

When you run the Add New Hardware Wizard, it may not detect a device that has been removed in Device Manager on a multiple-profile user system.

CAUSE

Removing a Plug and Play device from one profile and leaving it in another causes a flag to be set in the registry to prevent the device from being enumerated on the next startup, and may also cause the Add New Hardware Wizard to bypass the device. The flag exists only in the profile in which the device was removed.

RESOLUTION

To prevent this problem from occurring, disable the device in Device Manager instead of removing it. To disable a device, click the Disable In This Hardware Profile check box for the device in Device Manager.

To restore (or redetect) the device, remove it from all profiles and then run the Add New Hardware Wizard.


KBCategory: kbenv
KBSubcategory: win95 osr2
Additional reference words: 95


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: November 7, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.