Cannot Start Computer After Running DriveSpace on IBM Computer

Last reviewed: January 9, 1997
Article ID: Q160048
The information in this article applies to:
  • Microsoft Windows 95
  • Microsoft Plus! for Windows 95

SYMPTOMS

When you use DriveSpace to compress a drive on an IBM Aptiva or PS/1 computer, you may receive the following message when you start your computer after the compression process is finished or when DriveSpace restarts your computer during the compression process:

   Windows has disabled direct disk access to protect your long file-
   names. To override this protection, see the LOCK /? command for more
   information.

   The system has been halted. Press CTRL+ALT+DEL to restart your
   computer.

CAUSE

This problem can occur when you are running Ps1pfile.exe from your Autoexec.bat file. This program attempts to bypass the operating system and system ROM BIOS and write to the hard disk directly. When programs attempt to access the hard disk in this manner, Windows 95 prevents the program from doing so and displays the message.

RESOLUTION

To work around this problem, use one of the following methods:

  • If the message is displayed when you attempt to start your computer after the compression process is finished, configure your computer so that Ps1pfile.exe is allowed to write to all hard disks on your computer directly. To do so, follow these steps:

    1. Start Windows 95 in Safe mode and then use any text editor (such as

          Notepad) to open the Autoexec.bat file.
    

    2. Before the line that contains Ps1pfile.exe, insert a line similar to

          the following for each hard disk on your computer
    

             echo y | lock <drive>:\ > nul
    
          where <drive> is the hard disk letter. For example, if your computer
          contains drive C and drive H, insert the following lines before the
          line that contains Ps1pfile.exe:
    
             echo y | lock c:\ > nul
             echo y | lock h:\ > nul
    
          Note that lines for the hard disks on your computer may already
          exist in the file. To determine which hard disks currently exist on
          your computer, run DriveSpace and view the physical drives,
          compressed drives, and host drives that appear in the list of
          drives. To run DriveSpace, click the Start button, point to
          Programs, point to Accessories, point to System Tools, and then
          click DriveSpace.
    
       3. After the line that contains Ps1pfile.exe, insert a line similar to
          the following for each hard disk on your computer
    
             unlock <drive>: > nul
    
          where <drive> is the hard disk letter. For example, if your computer
          contains drive C and drive H, insert the following lines after the
          line that contains Ps1pfile.exe:
    
             unlock c: > nul
             unlock h: > nul
    
          Note that lines for the hard disks on your computer may already
          exist in the file.
    
       4. Save and then close the Autoexec.bat file.
    
       5. Restart your computer.
    
    
  • If the message is displayed when DriveSpace restarts your computer during the compression process, remove or disable the line in the Autoexec.bat file that contains Ps1pfile.exe. To do so, follow these steps.

    NOTE: The Ps1pfile.exe file may be necessary to use some of the Advanced Power Management (APM) features of Windows 95 and your IBM computer. If you are unable to use APM features reliably after removing the line that contains Ps1pfile.exe, insert the line again. If the message is displayed again after you insert the line, perform the steps listed above to work around the problem.

    1. Start a Windows 95 Safe-mode command prompt and then use any text

          editor (such Edit.com) to open the Autoexec.bat file.
    

    2. Remove or disable the line that contains Ps1pfile.exe. You should

          also remove or disable any lines that contain the LOCK or UNLOCK
          command that precede or follow the line that contains Ps1pfile.exe.
          For example, you may need to remove or disable lines similar to:
    

             echo y | lock c:\ nul
             c:\ps1tools\ps1pfile.exe
             unlock c: nul
    
          NOTE: To disable the first line above, you should modify the line
          so that it appears as follows (note that the second REM command is
          required):
    
             rem echo y | rem lock c:\ nul
    
       3. Save and then close the Autoexec.bat file.
    
       4. Restart your computer. When you restart your computer, DriveSpace
          should automatically continue the operation that it was performing
          when the message appeared.
    
    

STATUS

Microsoft is researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

When you install Windows 95 on a computer on which Ps1pfile.exe is running from the Autoexec.bat file, the Windows 95 Setup program automatically configures your computer so that Ps1pfile.exe is able to write directly to the hard disk. Configuring your computer in this manner prevents the message from appearing when you start your computer.

However, the Windows 95 Setup program is able to configure your computer so that Ps1pfile.exe is able to write directly to only the hard disks that currently exist. If a new drive is added, Ps1pfile.exe is unable to write directly to the new drive until you reconfigure your computer.

When you use DriveSpace to compress a drive, an additional logical drive is created. Because the new drive did not exist when you installed Windows 95, your computer is not configured so that Ps1pfile.exe can write directly to the drive. Therefore, if Ps1pfile.exe attempts to write directly to the drive when you start your computer, Windows 95 prevents it from doing so and displays the message.

The third-party product discussed in this article is manufactured by a vendor independent of Microsoft; we make no warranty, implied or other- wise, regarding this product's performance or reliability.


KBCategory: kbtool kberrmsg kb3rdparty
KBSubcategory: win95 winplus drvspace diskmem
Additional reference words: 95


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Last reviewed: January 9, 1997
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