Profiles and Briefcase May Not Work with Windows NT Server

Last reviewed: November 26, 1997
Article ID: Q160808
The information in this article applies to:
  • Microsoft Windows 95
  • Microsoft Windows 95 OEM Service Release versions 2, 2.1

SYMPTOMS

When you are using Briefcase or user profiles with files stored on a Windows NT server, you may experience one of the following problems:

  • If user profiles are enabled, the profiles are stored on a Windows NT server (to provide roving profiles), and the server has a very large number of shares, the user profile may not be downloaded from the server when a user logs on. The default user profile is used instead.
  • If Briefcase is used to synchronize with files stored on a Windows NT server, and the server has a very large number of shares, the synchronization operation may not work.
  • When user profiles are enabled and you try to copy a file from a Windows NT or NetWare server to the Briefcase, the copy operation is not successful. When this occurs, you may not receive an error message. Although you can copy files from the server to the local hard disk, you cannot copy to the Briefcase.

CAUSE

User profiles and Briefcase use the same API set to synchronize data on a local drive with data on the server. The network calls made result in a list of shares on the server being returned to the client. However, if there are too many shares on the server, the data buffer is not large enough to contain the full list of shares. If the share on which the data is located is not included in the partial list returned, the operation does not work.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 95. A fix to this problem is in development, but has not been regression tested and may be destabilizing in production environments. Microsoft does not recommend implementing this fix at this time. Contact Microsoft Technical Support for more information on the availability of this fix.

MORE INFORMATION

If this problem occurs with user profiles, the user profile cannot be downloaded from the Windows NT server, but an updated user profile can be saved to the Windows NT server when the user logs off. If this occurs, the user's profile on the Windows NT server is overwritten by the changed copy of the default profile. The previous user profile must then be restored to the Windows NT server from a recent backup.

For additional information about related issues, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q160807
   TITLE     : Cannot Connect to Windows NT Server with Many Shares


Additional query words: 95
Keywords : osr2 win95 kbnetwork kbfixlist
Version : 95
Platform : WINDOWS


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Last reviewed: November 26, 1997
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