Err Msg: Cannot Find a Device File That May Be Needed to Run...

Last reviewed: December 15, 1997
Article ID: Q166832
The information in this article applies to:
  • Microsoft Windows 95 OEM Service Release versions 2, 2.1

SYMPTOMS

When you restart your computer following the installation of the Dial-Up Adapter, you may receive the following error messages:

  • Cannot find a device file that may be needed to run Windows or a Windows application.
  • The Windows registry or SYSTEM.INI file refers to this device, but the device file no longer exists ...
  • If you still want to use the application associated with this device file, try reinstalling that application to replace the missing file.

The following files are listed as missing:
  • Vnetsup.vxd
  • Nwlink.vxd
  • Nwredir.vxd
  • Nscl.vxd
  • Vredir.vxd
  • Ndis.vxd
  • Ndis2sup.vxd
  • Vnetbios.vxd

Two additional dialog boxes may appear informing you that the following two files cannot be found:
  • Nwnp32.dll
  • Msnp32.dll
After you acknowledge these error messages, Windows starts normally but without Dial-Up Networking functionality.

CAUSE

This problem can occur if you install Dial-Up Networking or the Dial-Up Adapter and then cancel Setup while the Copying Files dialog box is displayed. The Dial-Up Networking files are not copied to the hard disk but the file names are added to the Windows 95 registry. When the computer is restarted, the files are requested and cannot be found.

RESOLUTION

NOTE: If you have previously set up Dial-Up Networking and have added items such as phone numbers, TCP/IP settings, and other protocols, record the information before you remove the Dial-Up adapter. Do the same for Network Adapter properties information if a network adapter is listed in Network properties.

To resolve this problem, remove and then reinstall Dial-Up Networking. To do so, follow these steps:

  1. In Control Panel, double-click Add/Remove Programs.

  2. Click the Windows Setup tab, and then click Communications.

  3. Click Details, and then click the Dial-Up Networking check box to clear it.

  4. Click Close, and then click OK.

  5. When you are prompted to restart Windows 95, do so.

  6. In Control Panel, double-click Add/Remove Programs.

  7. Click the Windows Setup tab, and then click Communications.

  8. Click Details, and then click the Dial-Up Networking check box to select it.

  9. Click Close, and then click OK.

  10. When you are prompted to restart Windows 95, do so.

If any additional protocols are needed, add the protocols using the Network tool in Control Panel.

NOTE: Check with your system administrator or Internet service provider to determine the required settings for Dial-Up Networking and TCP/IP.

For additional information about configuring Dial-Up Networking to work with an Internet service provider, see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q133219
   TITLE     : Connecting to the Internet Using a Service Provider

MORE INFORMATION

If you cancel the Dial-Up Adapter installation while the Copying Files dialog box is displayed, the installation proceeds and returns the following message:

  • You must now restart your computer before the new settings will take effect. Do you want to restart you computer now?

Because the files were not copied to the hard disk, you receive the error messages listed at the beginning of this article. Completing the installation of the files as outlined above resolves the issue.

For information about similar startup problems, see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q140010
   TITLE:      Microsoft Plus! Setup Inadvertently Installs NetWare
               Client

   ARTICLE-ID: Q137454
   TITLE:      Err Msg: Cannot Find a Device File...Vnetsup.vxd


Additional query words: 95
Keywords : dun osr2 win95 kbenv kberrmsg
Version : 95
Platform : WINDOWS


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Last reviewed: December 15, 1997
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