Memory Management Problems on Computers with Pentium Processors

Last reviewed: February 4, 1998
Article ID: Q179897
The information in this article applies to:
  • Microsoft Windows 95 OEM Service Release versions 2, 2.1
  • Microsoft Windows 95

SYMPTOMS

When you run multiple programs (especially MS-DOS-based programs) on a Windows-based computer that has insufficient system memory (RAM) and contains an Intel Pentium Pro or Pentium II processor, you may experience the following symptoms:

Windows 95 OEM Service Release 2 (OSR2) or 2.1 (OSR 2.1)

Information in memory may become unavailable or damaged, leading to unpredictable results. For example, copy and compare operations may not work consistently.

Windows 95

Your computer may stop responding (hang).

CAUSE

This behavior is an indirect result of certain performance optimizations in the Intel Pentium Pro and Pentium II processors. These optimizations affect how the Windows 95 Virtual Machine Manager (VMM) performs certain memory operations, such as determining which sections of memory are not in use and can be safely freed. As a result, the Virtual Machine Manager may free the wrong pages in memory, leading to the symptoms described earlier.

RESOLUTION

This issue is resolved by the following updated file for Windows 95 OEM Service Release 2 (OSR2) only:

   VMM.VXD version 4.00.1113  dated 9/24/97 11:13am  408,096 bytes

This issue is resolved by the following updated file for Windows 95 OEM Service Release 2.1 (OSR2.1) with the USB Supplement only:

   VMM.VXD version 4.03.1216  dated 9/23/97 12:16pm  427,552 bytes

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 95 OEM Service Releases 2 (OSR2) and 2.1 (OSR2.1). An update to address this problem is now available, but is not fully regression tested and should be applied only to computers experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft does not recommend implementing this update at this time. Contact Microsoft Technical Support for additional information about the availability of this update.

Microsoft has confirmed this to be a problem in Windows 95 (retail release). We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

For additional information about issues resolved by updates to this component, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q171284
   TITLE     : Problems Enumerating CardBus Devices with No Free IRQs

Keywords          : diskmem osr2 win95 kbhw kbfixlist
Version           : WINDOWS:95
Platform          : WINDOWS
Issue type        : kbprb


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Last reviewed: February 4, 1998
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