Desktop Folders Are Not Deleted Under Roving Profiles

Last reviewed: February 27, 1998
Article ID: Q181869
The information in this article applies to:
  • Microsoft Windows 95
  • Microsoft Windows 95 OEM Service Release versions 1, 2, 2.1, 2.5

SYMPTOMS

When roving profiles are implemented, Desktop or Start Menu folders that are not empty when you delete them from the client computer are not deleted from the server profile when you log off. When you log back on, the folders are restored, and are empty.

Note that if an empty folder is deleted, it is deleted from the server profile, and is not restored during logon.

CAUSE

This problem occurs because during the logoff process, in order to synchronize the server copy of the desktop with the client, the folder structure of the client desktop is first enumerated in a hierarchical order, parent folders first. The server copy of the desktop is also enumerated, and compared to the client hierarchy. Differences found between them are the source of a work list, that includes file and folder deletions to be performed. The work list is processed in the same order as the enumeration, and since parent folders are listed first, they are not empty when the delete request is issued to the server.

RESOLUTION

This issue is resolved by the following updated file for Windows 95, all versions, which adds functionality to optimize the order in which folder deletions are requested:

   MPRSERV.DLL version 4.00.958  dated 2/25/98 09:58am  127,488 bytes

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 95 (retail release), and Microsoft Windows 95 OEM Service Releases 2 (OSR2) and 2.1 (OSR2.1). An update to address this problem is now available, but is not fully regression tested and should be applied only to computers experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft does not recommend implementing this update at this time. Contact Microsoft Technical Support for additional information about the availability of this update.


Additional query words: roaming
Keywords : osr1 osr2 win95 kbenv kbnetwork kbfixlist
Version : WINDOWS:95
Platform : WINDOWS
Issue type : kbprb


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 27, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.