Troubleshooting STOP: 0x0000007B or "0x4,0,0,0" Error

Last reviewed: February 4, 1998
Article ID: Q122926
The information in this article applies to:
  • Microsoft Windows NT Workstation versions 3.5, 3.51, and 4.0
  • Microsoft Windows NT Server versions 3.5, 3.51, and 4.0

SYMPTOMS

When you restart your computer, you may receive one of the following error messages:

  • STOP: 0x0000007B Inaccessible Boot Device
  • Setup has encountered a fatal error that prevents it from continuing. Contact your software representative for help. The following status codes will assist them "0x4, 0, 0, 0"

CAUSE

This problem may occur if one or more of the following conditions exists:

  1. Your computer is infected with a boot sector virus.

  2. A device driver required by your boot controller is not configured to start at boot time or is corrupt. If during a WINNT /B installation no mass storage device was detected.

  3. A resource conflict exists between the boot controller and another controller in the system or between SCSI devices.

  4. Drive translation is not being performed or was changed.

  5. The boot volume is corrupt and cannot be mounted by Windows NT.

  6. Information in the Windows NT registry about which device drivers load at start up is corrupt.

  7. If this error occurred during Windows NT Setup while reading Windows NT Setup floppy disk 2, you may have the Drive Swapping option enabled in your computer BIOS.

  8. Using winnt /b as the installation method may present a timing issue for the disk controller. The controller is not given enough time to respond and identify itself and is therefore detected incorrectly or not at all.

RESOLUTION

To resolve this problem, use the appropriate method:

Method 1

Check any diskettes for viruses that may have been used in the computer since the last time you were able to successfully restart Windows NT.

NOTE: You may need to use more than one brand of virus detection software to detect and remove various viruses.

If a virus has infected the Windows NT computer and a virus detection program cannot remove the virus and repair the system, you will have to reinstall Windows NT. For more information on how to protect the boot sector from viruses in Windows NT, see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q122221
   TITLE     : How to Protect Boot Sector from Viruses in Windows NT



SOLUTION 2

Windows NT requires a mini-port driver to communicate with the boot controller. If the device driver is corrupt or incompatible with your controller, you can replace it by copying a new drive to the %systemroot%\system32\drivers folder or through the Emergency Repair process. On computers running on a SCSI controller or ATAPI enabled systems, SCSIPORT.SYS and DISK.SYS (Windows NT 4.0 only) device drivers are also required to successfully boot.

If you attempt a "WINNT /B" installation, you may receive a STOP 0x7B before mass storage detection takes place. To work around this, when the computer reboots after the initial file copy, press F6 as soon as "Setup is inspecting your computers hardware configuration" is displayed. This will allow you to add a mass storage device at the very beginning of text mode setup.

   ARTICLE-ID: Q125933
   TITLE     : STOP 0x0000007B: Inaccessible Boot Device After Removing
               CD-ROM

   ARTICLE-ID: Q164471
   TITLE     : Replacing System Files Using a Modified Emergency Repair
               Disk

SOLUTION 3

If an IRQ or I/O port address conflict exists between your boot controller and another controller in the system, Windows NT will either hang or stop with the Stop 0x0000007B error message. If you recently added new hardware, remove the new hardware or re-configure it so it does not conflict with the resources of any other installed controllers.

Check the SCSI chain for proper termination. Remove any non-essential SCSI devices or check to ensure each SCSI ID is unique.

   ARTICLE-ID: Q102651
   TITLE     : Required Settings for Adaptec 1510 SCSI Host Adapter


SOLUTION 4

The Windows NT Boot partition must exist within the first 1024 cylinders of the boot device. This is due to restrictions of the INT-13 BIOS call used to start the operating system. Check your CMOS settings for LBA support on IDE based systems, or your SCSI controllers BIOS settings for enabling drive translation for drives greater than 2GB.

   ARTICLE-ID: Q114841
   TITLE     : Windows NT Boot Process and Hard Disk Constraints


SOLUTION 5

If the file system is corrupt and Windows NT cannot mount the boot volume during start, move the drive to another machine running Windows NT and run the CHKDSK command on that drive. Alternately, attempt to create a parallel installation of Windows NT on the drive in a separate directory. The Windows NT Setup program checks the integrity of the volume prior to copying files and may fix some problems.

SOLUTION 6

If the SYSTEM Hive in the Windows NT registry is corrupt, it may prevent Windows NT from loading the Mini-port device driver required by the boot controller. To resolve this problem, use one of the following methods:

  • Start from the three Windows NT setup disks and use the Repair utility. When prompted, select to inspect registry files, and then only replace the System Configuration Registry hive. This hive contains information about which device drivers and services start during start up.
  • Install a parallel copy of Windows NT into a separate directory, and then use Registry Editor to modify the System hive in the Windows NT registry to correct the invalid or missing information.

          ARTICLE-ID: Q165748
    
          TITLE     : How to Disable a Service or Device that Prevents NT from
                      Booting
    
    

SOLUTION 7

Many computers are equipped with a 5.25-inch and a 3.5-inch floppy diskette drive in one single unit. When you install Windows NT on a computer with this floppy drive unit, the STOP 0x7B error message may appear during Setup while Windows NT Setup disk 2 is being read. To resolve this problem, disable the Drive Swapping option in your system BIOS. For information about correcting this problem, see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q126423
   TITLE     : STOP: 0x0000007B "Inaccessible_Boot_Device" During Setup
               Disk2


Additional query words: 3.50 3.51 4.00 0x7B Virus trap stop

SOLUTION 8
----------

Install using the three boot floppies, a bootable CD, winnt or winnt32.
Install the device driver recommended by hardware vendor if one is
available.

Keywords : ntstop kbusage kbfaq
Version : 3.5 3.51 4.0
Platform : winnt
Issue type : kberrmsg


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Last reviewed: February 4, 1998
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