Error Running RASPHONE.EXE and RASADMIN.EXE in Windows NT

Last reviewed: August 22, 1996
Article ID: Q125450
The information in this article applies to:
  • Microsoft Windows NT operating system version 3.1
  • Microsoft Windows NT Advanced Server version 3.1
  • Microsoft Windows NT Workstation version 3.5
  • Microsoft Windows NT Server version 3.5

SYMPTOMS

When you run RASPHONE.EXE (Remote Access Phone Book) and start the Remote Access Service in RASADMIN.EXE (Remote Access Administrator's utility), the following error messages may appear (in the respective versions of Windows NT):

Windows NT version 3.1

RASPHONE.EXE:

   The dynamic link library RASAPI32.DLL could not be found in
   the specified path <system and user defined path list>

RASADMIN.EXE:

   Error starting Remote Access Server Service on <computername>
   Check the Event log on <computername> for details.

   Error 2185: The Service name is invalid.

Windows NT version 3.5

RASPHONE.EXE:

   An application error log is being generated
      RASPHONE.EXE
   Exception: access violation (0xc0000005), Address: 0x00000000

The error message for RASADMIN.EXE is the same as for Windows NT version 3.1.

CAUSE

This problem occurs if Remote Access Service (RAS) is not installed. When you install Windows NT, RASPHONE.EXE and RASADMIN.EXE are installed and placed in the %systemroot%\SYSTEM32 subdirectory. The program items are not present, but you can run these programs from File Manager.

RESOLUTION

To correct this problem, install the Remote Access Service. To install this service, do the following:

  1. In the Control Panel window, choose the Network icon.

  2. In the Network Settings dialog box, choose the Add Software button.

  3. In the Add Network Software dialog box, select Remote Access Service, and then choose the Continue button.

  4. Specify the location of the source files.

  5. After the Remote Access Service is installed, restart Windows NT.


KBCategory: kbnetwork
KBSubcategory: ntras NTSrvWkst
Additional reference words: prodnt 3.10 3.50


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: August 22, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.