Printers are not Displayed in Connect To Printer Dialog Box

Last reviewed: September 3, 1996
Article ID: Q129458
The information in this article applies to:
  • Microsoft Windows NT operating system version 3.1
  • Microsoft Windows NT Advanced Server version 3.1
  • Microsoft Windows NT Workstation version 3.5
  • Microsoft Windows NT Server version 3.5

SYMPTOMS

When you run Windows NT Print Manager, choose Connect To Printer from the Printer menu, and browser a domain, it's printers are not displayed.

CAUSE

This problem occurs when the domain name includes an exclamation point. Because the exclamation point (!) character is used as a separator by the code that enumerates printers, the printers do not get enumerated correctly.

WORKAROUND

To work around this problem, do not use the exclamation point character in your domain or printer names.


KBCategory: kbnetwork
KBSubcategory: ntdomain
Additional reference words: 3.10 3.50 prodnt enumerate


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: September 3, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.