Users Without System32 Permissions Cannot Log On

Last reviewed: March 20, 1997
Article ID: Q137155
The information in this article applies to:
  • Microsoft Windows NT Workstation versions 3.5, 3.51, and 4.0
  • Microsoft Windows NT Server versions 3.5, 3.51, and 4.0

SYMPTOMS

When you try to log on to your Microsoft Windows NT computer, you may experience one of the following:

  • With Microsoft Windows NT version 3.5:

    You see the initial background screen that is shown during logon, but you never see Program Manager and no messages are displayed.

    -or-

  • With Microsoft Windows NT version 3.51:

    You see the Shutdown in Progress dialog box, then Microsoft Windows NT shuts down and displays the Shutdown Complete and Restart buttons.

    -or-

  • With Microsoft Windows NT version 4.0:

    After typing your user information, you are returned to the "Press Ctrl-Alt-Del to log on" dialog box.

CAUSE

The user account does not have permissions to the %SystemRoot%\System32 directory of the local computer. Normally, the Everyone group is given Change permissions (Read, Write, Execute, Delete) to this directory. If these permissions are denied, the user cannot access the system, even if the user attempts to log on as an administrator of a domain.

If you do not have the necessary permissions to the local computer, you should get a dialog box that informs you of this. When you click OK, you should get the logon screen. The Shutdown sequence should not be started.

This also happens on DEC Alpha computers that have the System files on a file allocation table (FAT) partition. This is because of the "Secure the System Partition" option in Disk Administrator.

By default, this is turned off. If it is on, no users except for users in the Administrator group can logon.

RESOLUTION

To correct this problem, apply specific permission for the individual user on the %Systemroot%\System32 directory, or give the Everyone group a minimum of Change permission for this directory. To change specific permissions, install another copy of Microsoft Windows NT to a new directory. Log on as the same user with the same user privileges and change the permissions for the original System32 directory.

To work around this problem in Microsoft Windows NT version 3.51, apply the fix mentioned below. Windows NT 4.0 already has this fix included and is responding properly.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows NT version 3.51. This problem was corrected in the latest Windows NT 3.51 U.S. Service Pack. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K


Additional query words:
Keywords : kbbug3.51 kbenv ntfilesys ntsecurity NTSrvWkst
Version : 3.5 3.51 4.0
Platform : WinNT


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 20, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.