System Error 53 When Connecting to a FQDN

Last reviewed: October 28, 1997
Article ID: Q137565
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

When you attempt to connect to a Fully Qualified Domain Name (FQDN) from a Windows NT computer, you may receive the following error message:

   System error 53 has occurred. The network path was not found.

NOTE: You may also receive this error if you misspell the name of the remote computer.

CAUSE

When you attempt to establish a NetBIOS over TCP/IP connection (such as a file share or print share) to a remote computer, your computer must:

  • Locate the IP address for the remote computer.
  • Establish a TCP/IP connection to the remote computer.
  • Establish a NetBIOS session to one of the NetBIOS names registered on the remote computer.

Windows NT 4.0 computers use the following logic when using a FQDN for this process: (for example, when you type "net use \\host1.domain2.com\public")
  • Use a DNS or hosts file to locate the IP address for host1.domain2.com.
  • Establish a TCP/IP connection to that IP address.
  • Try to establish a NetBIOS session to the NetBIOS name "host1".
  • If that fails, send an Adapter Status Query to the IP address, and parse the returned NetBIOS name table for the server name.
  • Establish a NetBIOS session to the server name.

For cases when the hostname does not match the NetBIOS (server) name, this process relies upon the Adapter Status Query, which is a UDP datagram sent to UDP port 137. In some cases, such as certain firewall environments, the Adapter Status Query may fail.

RESOLUTION

To resolve this problem, obtain the following fix or wait for the next Windows NT service pack.

This fix should have the following time stamp:

   10/22/97  12:25p  263,824 Rdr.sys  (i386)
   10/22/97  12:22p  510,352 Rdr.sys  (alpha)

An updated version of Rdr.sys offers a new registry parameter to slightly change the above logic:
  • Use a DNS or hosts file to locate the IP address for host1.domain2.com.
  • Establish a TCP/IP connection to that IP address.
  • Try to establish a NetBIOS session to the NetBIOS name "host1".
  • If that fails, try to establish a NetBIOS session to the NetBIOS name
       "*SMBSERVER      ".
    
    
Please see the following article in the Microsoft Knowledge Base for more information on the *SMBSERVER name and why it is registered on Windows NT servers:

   ARTICLE-ID: Q161431
   TITLE     : Connecting to NetBIOS Resources Using DNS Names or IP
               Addresses

The new registry parameter that allows control of this behavior is:

   Value: FqdnUsesSmbServerName
   Key: HKLM\CurrentControlSet\Services\Rdr\Parameters
   Value Type: REG_DWORD - Boolean
   Valid Range: 0,1 (False,True)
   Default: 0 (False)
   Description: Setting this parameter to "1" causes your computer to try a
                NetBIOS session to the name "*SMBSERVER      " instead of
                using an Adapter Status Query when the hostname part of a
                FQDN does not match the NetBIOS computername on the target
                system.

NOTE: Service Pack 3 must be applied to Windows NT 4.0 prior to applying this fix.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. A supported fix is now available, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.


Additional reference words: 4.00
Keywords : kbbug4.00 kbfix4.00 NTSrvWkst nttcp kbnetwork
Version : WinNT:4.0
Platform : winnt
Issue type : kbbug
Solution Type : kbpatch


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Last reviewed: October 28, 1997
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