Printing to LPD Printer Is Slow or Fails with Windows NT

Last reviewed: February 9, 1998
Article ID: Q141708
The information in this article applies to:
  • Microsoft Windows NT Workstation versions 3.51 Service Pack 5 and 4.0
  • Microsoft Windows NT Server versions 3.51 Service Pack 5 and 4.0

SYMPTOMS

Delays may result when you print to a Windows NT 3.51 Service Pack 5 (SP5) or Windows NT 4.0 print server connected through line printer remote (LPR) to a shared printer using the Line Printer Daemon (LPD) service.

CAUSE

In Windows NT version 3.51 Service Pack 4 (SP4) and earlier, the LPR service used TCP ports 721 through 731 for LPR connections. This complied with RFC 1,179 but limited performance because it only allowed 11 TCP ports to be in use by the service at one time. Per RFC 1,122, each port must not be reused for four minutes (2 * Maximum Segment Lifetime as defined in RFC 1,122).

A change in Windows NT 3.51 SP5 and Windows NT 4.0 up to Service Pack 2 (SP2) provides a performance enhancement for LPR printing. This enhancement allows TCP ports 512-1,023 to be used for outbound LPR connections but deviates from RFC 1,179 and therefore causes problems with some applications.

RESOLUTION

To revert back to the RFC 1,179 specification, use the steps listed in the appropriate section below.

Windows NT 3.51 SP5

To revert Windows NT 3.51 SP5 back to being RFC compliant, obtain the hotfix mentioned below or regress back to the SP4 files, by copying the following files into your %Systemroot%\System32 folder:

(from the Windows NT 3.51 SP4 CD)

   Lprmon.dll

(from the original Windows NT 3.51 CD)

   Lprhelp.dll
   Lpdsvc.dll

NOTE: It is necessary to restart the Spooler service for the changes to take affect. To stop the Spooler service, type the following command at an MS-DOS command prompt:

   net stop spooler

To restart the Spooler service, type the following command at an MS-DOS command prompt:

   net start spooler

Windows NT 4.0 SP2 and earlier

Windows NT 4.0 SP2 and earlier can become RFC complaint by applying the latest service pack for Windows NT 4.0.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. This problem was corrected in the latest Microsoft Windows NT 4.0 U.S. Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K

Microsoft has confirmed this to be a problem in Windows NT version 3.51. A fix to this problem is in development, but has not been fully regression tested and may be destabilizing in production environments. Microsoft does not recommend implementing this fix at this time. Contact Microsoft Technical Support for more information on the availability of this fix.

MORE INFORMATION

With Windows NT 4.0 Service Pack 3, the default TCP Ports for LPR are 721- 731. Changes can also be made so that ports greater than 1,023 can be used to prevent LPR from running out of available ports or conflicting with reserved ports.

For more information about available LPR port options with Service Pack 3, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q179156
   TITLE     : Updated TCP/IP Printing Options for Windows NT 4.0 SP3 and
               Later

For more information about changes to LPR in Windows NT 3.51, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q153666
   TITLE     : Updated TCP/IP Printing Components for Windows NT 3.51


Additional query words: slow stuck
Keywords : kbbug3.51 kbbug4.00 kbfix4.00.sp3 ntprint NTSrvWkst nttcp kbprint
Version : WinNT:3.51,4.0
Platform : winnt
Issue type : kbbug
Solution Type : kbservicepack


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Last reviewed: February 9, 1998
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