Setup Halts with "Windows Has Disabled Direct Disk Access"

Last reviewed: August 13, 1997
Article ID: Q154647
The information in this article applies to:
  • Microsoft Windows NT Server versions 3.5, 3.51, and 4.0
  • Microsoft Windows NT Workstation versions 3.5, 3.51, and 4.0

SYMPTOMS

When you are installing Windows NT Workstation or Server version 4.0 from a flat directory on the hard disk, Setup may halt with the following message after setting the location of the source files:

   Windows has disabled direct disk access to protect your long file
   names. To override this protection, see the Lock /? Command for more
   information. The system has been halted. Press CTRL-ALT-DEL to restart
   your computer.

CAUSE

The Microsoft Windows 95 system files have been installed on the hard disk.

RESOLUTION

Restart the computer, and then type "lock c:" (without quotation marks) at the command prompt. Windows 95 returns the following message:

   WARNING: The lock command enables direct disk access by programs that
   can CORRUPT file names and/or DESTROY disk data, resulting in the loss
   of files on your disk.

   Are you sure (Y/N)?

Press Y to return to the command prompt, and then run Windows NT Setup again.

MORE INFORMATION

Windows 95 includes volume-locking code to protect long file names from programs that make absolute INT25 read and INT26 write disk calls by- passing the FAT. The Windows 95 Command.com includes a LOCK command to allow you to perform an exclusive read/write lock for use with programs that do not use the volume-locking APIs included in Windows 95.


Additional query words:
Keywords : NTINTEROP NTSrvWkst kbsetup kberrmsg kbsetup
Version : 3.5 3.51 4.0
Platform : winnt
Issue type : kberrmsg


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Last reviewed: August 13, 1997
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