Error Message: Unable to Connect to all of the Roots...

Last reviewed: March 27, 1997
Article ID: Q155126
The information in this article applies to:
  • Microsoft Windows NT Server version 4.0
  • Microsoft Windows NT Workstation version 4.0

SYMPTOMS

When you connect to a remote registry in Registry Editor by clicking Connect Network Registry on the Registry menu, the following message is displayed:

   Unable to connect to all of the roots of the computer's registry.
   Disconnect from the remote registry and then reconnect before trying
   again.

Or, when you open a key in a remote registry, the following message is displayed:

   Cannot open <KEY>: Error while opening key.

CAUSE

You are using Regedit.exe to edit the remote registry.

RESOLUTION

To edit the registry on a remote computer set up for remote administration, use Regedt32.exe instead of Regedit.exe.


Additional query words:
Keywords : kbtool ntregistry ntsrvwkst ntutil prodnt
Version : 4.0
Platform : WinNT
Issue type : kberrmsg


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 27, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.