Services Set to Interact With Desktop May Fail to Start

Last reviewed: March 6, 1998
Article ID: Q157913
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

There are several services that are configured to start with the interactive desktop. If a user logs on immediately after Windows NT starts and then immediately logs off, a service configured to interact with the desktop may fail to start. A message may appear that states:

   The application failed to initialize because the window station is
   shutting down.

After you log on a second time, Service Control Manager (SCM) logs two events in the system event log:
  • ID 7009 Timeout (120000 milliseconds) waiting for service to connect.
  • ID 7000: The <service name> service failed to start due to the following error:

          The service did not respond to the start or control request in a
          timely fashion.
    

CAUSE

After SCM calls CreateProcess to start the service process, it expects the service to connect to a named pipe provided by SCM. A service does this by calling StartServiceCtrlDispatcher early after startup.

When a user logs off, the Win32 subsystem marks the window station as Pending Shutdown. If Kernel32.dll finds this flag, it does not load. The service process never gets to the point where it can register with SCM. SCM does not check for this situation and, therefore, logs the events mentioned above. SCM does not try to start the service again.

RESOLUTION

To resolve this problem, obtain the following fix or wait for the next Windows NT service pack.

This fix should have the following time stamp:

   01/28/98   3:05p               323,344 User32.dll (Intel)
   02/03/98   3:11p             1,237,520 Win32k.sys (Intel)

   01/28/98  03:02p               579,856 User32.dll (Alpha)
   02/03/98  03:08p             2,050,608 Win32k.sys (Alpha)

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. A supported fix is now available, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

MORE INFORMATION

You can work around this problem by not logging off immediately after logging on.

Keywords          : kbbug4.00 kbfix4.00 ntboot NTSrvWkst kbenv
Version           : WinNT:4.0
Platform          : winnt
Issue type        : kbbug
Solution Type     : kbfix


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Last reviewed: March 6, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.