Proper Backup of Open Files Using Ntbackup

Last reviewed: September 4, 1997
Article ID: Q159218
The information in this article applies to:
  • Microsoft Windows NT Workstation versions 3.51 and 4.0
  • Microsoft Windows NT Server versions 3.51 and 4.0

SYMPTOMS

Files may not be properly restored with a backup program (such as Windows NT Backup).

CAUSE

This problem can be caused by either of the following:

  • Corrupt file

    Some third-party backup programs set the following value to 1 during setup while Windows NT Backup sets this value to 0:

          \\HKEY_CURRENT_USER\Microsoft
    
             \Ntbackup\Backup Engine\Backup files inuse
    
       Open files are generally in an inconsistent state and any attempt to
       back up these files may cause corruption (for example, WINS and DHCP
       databases).
    
    
  • Missing file

    If the value above is set to 0, the backup program skips open files; therefore, some files may be missing when you restore from backup.

RESOLUTION

Perform one of the following to resolve this problem:

  • WARNING: Using Registry Editor incorrectly can cause serious, system-wide problems that may require you to reinstall Windows NT to correct them. Microsoft cannot guarantee that any problems resulting from the use of Registry Editor can be solved. Use this tool at your own risk.

    Set the following value to 0:

          \\HKEY_CURRENT_USER\Microsoft
    
             \Ntbackup\Backup Engine\Backup files inuse
    
    
  • Make sure a consistent file is available for backup before you start the backup. To do this, perform one of the following:

        - Application method
    

          Use a utility for that application file that creates a good backup
          while that file is open. For example, "RDISK -s" backs up the
          registry in the \%SystemRoot%\Repair folder.
    

          NOTE: When performing a remote backup of any server's registry, you
          must run "RDISK -S" or "RDISK /s-" on that server first because
          remote registries are not available to be backed up over the network.
    

        - System method
    

          Close the files before backup (for example, stop logons, close
          current sessions with existing clients, and stop all non-essential
          services). You may be able to accomplish this by using the AT command
          or the Command Scheduler (Winat.exe).
    

        - Application and System method
    

          The best approach may be to use both methods to make sure all data is
          accessible from a backup and to test your plan fully before
          implementing it.
    

MORE INFORMATION

If the following value is 1, backup programs attempt to back up open files:

   \\HKEY_CURRENT_USER\Microsoft\Ntbackup\Backup Engine\Backup files inuse
Keywords          : nt32ap ntbackup NTSrvWkst ntutil
Version           : WinNT:3.51,4.0
Platform          : winnt
Issue type        : kbhowto


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: September 4, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.