Telnet to Port 135 Causes 100 Percent CPU Usage

Last reviewed: October 15, 1997
Article ID: Q162567
The information in this article applies to:
  • Microsoft Windows NT Workstation versions 3.51 and 4.0
  • Microsoft Windows NT Server versions 3.51 and 4.0

SYMPTOMS

When a client uses the telnet utility to connect to port 135 of a computer running Windows NT Server, and then types more than 10 random characters and disconnects, the server CPU usage jumps to 100 percent and does not come back down until the server is restarted.

CAUSE

This problem is caused by a problem with the remote procedure call (RPC) components in Windows NT.

RESOLUTION

To resolve this problem, download and install the appropriate file:

Windows NT 3.51

This hotfix has been posted to the following Internet location:

   ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/NT351/
   hotfixes-postSP5/rpc-fix

Windows NT 4.0

This hotfix has been posted to the following Internet location:

   ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/NT40/
   hotfixes-postSP2/rpc-fix

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 3.51 and 4.0. This problem was corrected in the latest Microsoft Windows NT 4.0 U.S. Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K


Additional query words: Telnet RPC crash hang max prodnt
Keywords : kbbug3.51 kbbug4.00 kbfix4.00.sp3 NTSrvWkst nttcp kbnetwork kbbuglist kbfixlist
Version : 3.51 4.0
Platform : winnt
Issue type : kbbug
Solution Type : kbservicepack


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Last reviewed: October 15, 1997
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