CLOCK Hangs and Consumes 90% CPU When Set to Digital Display

Last reviewed: May 19, 1997
Article ID: Q163936
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

Clock.exe may cause the computer to stop responding (hang) and then consume 90 percent of the CPU time when set to Digital Display under specific circumstances.

CAUSE

The array for the New Title was too small to hold the contents of the Short Date Format of dddd/MMMM DD/yyyy.

RESOLUTION

Use a different Short Date style that is not as long.

You can also obtain the hotfix mentioned below.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. This problem was corrected in the latest Microsoft Windows NT 4.0 U.S. Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K


Additional query words: dhcp
Keywords : kbbug4.00 kbfix4.00.sp3 nt32ap NTSrvWkst prodnt kbnetwork kbbuglist
Version : 4.0
Platform : winnt
Issue type : kbbug
Solution Type : kbservicepack


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Last reviewed: May 19, 1997
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