Unattended Installation of RAS May Fail

Last reviewed: December 19, 1997
Article ID: Q165094
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

When you try to install the RAS client through Unattend.txt, it may result in the following error message when connecting to a site:

   Rasman.exe - DLL Initialization failed.
   Initialization of the dynamic link library
   C:\winnt\system32\rasser.dll failed. The process is terminating
   abnormally.

Followed by:

   Error Connecting to <Connectoid Name>
   Error 665: The port is not configured for remote access.

CAUSE

This is because the Serial.ini file is not created during an unattended installation. The Serial.ini file is not part of the Windows NT 4.0 installation set, but is created by the Remote Access Setup wizard.

RESOLUTION

To correct the problem after the unattended installation has completed, simply create a blank Serial.ini file in the %SystemRoot%\System32\RAS directory. Another workaround is to launch the Remote Access Setup wizard by clicking Properties for the Remote Access Service on the Service tab in the Control Panel Network tool.

To correct the problem during an unattended installation can be accomplished by either of the following methods:

This workaround assumes that you are installing off of a server and not the actual CD-ROM.

  1. Create a Serial.ini in the I386 directory. Make sure the file contains at least some type of data.

  2. Edit the Txtsetup.sif file in the I386 directory. Add the following entry to the [SourceDisksFiles] section:

          serial.ini   = 1,,,,,,,7,0,0
    
    

  3. Edit the Dosnet.inf file, and add the following entry to the [Files] section:

          d1,serial.ini
    

  4. Run your unattended setup.

An alternate method would be to create a batch file that runs during the unattended installation that copies the Serial.ini file to the %SystemRoot%\System32\RAS directory.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Keywords          : kbbug4.00 NTRAS NTSrvWkst kbsetup
Version           : WinNT:4.0
Platform          : winnt
Issue type        : kbbug
Solution Type     : kbworkaround


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: December 19, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.