TrueType Not Printing on Remote Print Servers

Last reviewed: November 23, 1997
Article ID: Q165587
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

When printing from a Windows NT 4.0 client to a Windows NT 4.0 computer sharing a printer, some documents will print with the wrong font. One single job may print correctly, but successive jobs may not print correctly. If the printer is paused when these jobs are spooled, they print correctly.

CAUSE

This problem occurs when printing multiple documents that contain TrueType fonts not available on the print server: if a job containing font information is present in the printer queue when another such job starts spooling, the font will not be used for the latter job. As long as the first job remains in the printer queue, all jobs that start spooling to the printer will not include the necessary font information if the job uses TrueType fonts that the print server does not have available.

WORKAROUND

To work around this problem, install all TrueType fonts available to print clients on the Windows NT print server.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. This problem was corrected in the latest Microsoft Windows NT 4.0 U.S. Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K


Additional query words: prodnt 4.00 garbage bad incorrect download ttf
Keywords : kbbug4.00 ntprint NTSrvWkst kbnetwork
Version : WinNT:4.00
Platform : winnt
Issue type : kbbug


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: November 23, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.