WinNT Err: The System Cannot Find the File Specified with RAS

Last reviewed: December 9, 1997
Article ID: Q165846
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

SYMPTOMS

When you attempt to connect a Remote Access Service (RAS) client to a Windows NT RAS Server computer, the connection attempt fails and you may receive the following error message:

   Checking network protocol connections
   TCP/IP cp reported error 2.
   The system cannot find the file specified

CAUSE

An incorrect registry entry refers to another registry entry that does not exist.

RESOLUTION

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it.

On the RAS client, there are numbered entries for each installed network adapter under the following registry key:

   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT
   \CurrentVersion\NetworkCards

   NOTE: The above registry key is one path; it has been wrapped for
   readability.

Under normal circumstances, each entry will have a ServiceName value that refers to a registry key under the following key:

   HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

  • Start Registry Editor (Regedt32.exe).

  • Check each NetworkCards entry and confirm that there is a corresponding Services entry. If a NetworkCards entry refers to a service that does not have a corresponding Services key, delete the entire numbered key (Do not delete any other NetworkCards entries, and do not delete the entire NetworkCards key).

  • Quit Registry Editor and retry the RAS connection.
    Keywords          : NTRAS nttcp
    Version           : WinNT:4.0
    Platform          : winnt
    Issue type        : kbprb
    Solution Type     : kbworkaround

  • ================================================================================


    THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

    Last reviewed: December 9, 1997
    © 1998 Microsoft Corporation. All rights reserved. Terms of Use.