FPNW Server Returns Error When User Opens More Than 256 Files

Last reviewed: September 25, 1997
Article ID: Q166183
The information in this article applies to:
  • Microsoft File and Print Services for NetWare version 4.0

SYMPTOMS

When a user is attempting to open more than 256 files on a Microsoft File and Printer Services (FPNW) server, they may receive an indication that too many files are opened on the remote server.

One such indication might be the following error message:

   Too many files are opened on a remote server. This error should only be
   returned by the NT redirector on a remote drive.

CAUSE

This problem occurs because there is a hardcoded limit of 256 open files per user.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. This problem was corrected in the latest Microsoft Windows NT 4.0 U.S. Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K


Additional query words: 4.00 prodnt
Keywords : kbbug4.00 kbfix4.00 kbfix4.00.sp2 ntnetserv NTSrvWkst kbenv kbnetwork kbbuglist kbfixlist
Version : 4.0
Platform : winnt
Issue type : kbbug
Solution Type : kbservicepack


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: September 25, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.