Creating an SFM Volume on Large Partition Causes a Stop 0x24

Last reviewed: December 29, 1997
Article ID: Q166571
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

Shortly after you create a Macintosh volume on a partition larger than approximately seven (7) GB with a large number of files, the system may crash with a STOP 0x24 error in NTFS_FILE_SYSTEM (NTFS.SYS).

CAUSE

The AppleTalk protocol driver Afp.sys, depletes the memory pool allocated to non-paged pool while indexing a Services for Macintosh (SFM) volume.

This problem may also occur when the Services for Macintosh (SFM) server is experiencing performance problems, Event ID 12053 errors, or indexing problems. See the following Microsoft Knowledge Base articles for more information:

   ARTICLE-ID: Q136300
   TITLE     : Event ID 12053 Caused by Macintosh Client Disconnect

   ARTICLE-ID: Q147909
   TITLE     : Troubleshooting MacVolume Creation Errors

RESOLUTION

Increase the non-paged pool memory available to kernel or to reduce the number of files on the SFM volume. The amount of non-paged pool available to kernel is a fixed value that is based upon the total RAM in the system, so if you increase the RAM you will increase the non-paged pool available to kernel.

   -or-

Obtain the following fix or wait for the next Windows NT service pack.

MORE INFORMATION

This problem will generally only occur on a partition with 100,000 or more files that take up 7 to 8 GB or more disk space. When a SFM volume is created, the service will start indexing the partition. The indexing routines create memory structures that consume a large amount of non- paged pool memory and if your volume is large enough and has enough files, you will run out of non-paged pool and the system will stop responding. In most cases, this results in a STOP 0x24 in NTFS, although it can occur when another kernel-mode driver attempts to allocate resources that require non-paged pool memory.

The system may simply be slow and unresponsive for the first 20 to 40 minutes after creating the Macintosh volume. This is because of the large amount of kernel memory being used by SFM. If SFM is able to complete the indexing without running out of non-paged pool memory the memory will be freed and the system will return to normal. There should be no problems after this unless enough changes occur that a full re-indexing is necessary. In this case, SFM will have to repeat the procedure.

The simplest way to identify this problem is to run Performance Monitor after you create the SFM volume and watch the Memory\Pool Nonpaged Bytes counter. If a constant increase in non-paged pool bytes occurs over a 20 to 30 minute period of time, resulting in large amount (20 to 30 MB or more) of non-paged pool, you may be experiencing this problem.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. A supported fix is now available, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.


Additional query words: sfmsrv afp 0x00000024
Keywords : kbbug4.00 kbfix4.00 ntmac NTSrvWkst kberrmsg
Version : WinNT:4.0
Platform : winnt
Hardware : ALPHA x86
Issue type : kbbug
Solution Type : kbfix


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Last reviewed: December 29, 1997
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