Print Setup Dialog Box May Take a Long Time to Display

Last reviewed: December 4, 1997
Article ID: Q169131
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

Applications that use the print setup common dialog take a long time, 40 to 60 seconds, to display the print setup dialog box. This delay only occurs when the default printer name is longer than 32 characters.

CAUSE

This problem occurs when an application uses the common dialog (Comdlg32.dll) routine for print setup (PrintDlg) and specifies a truncated default print queue name. Because the truncated print queue name does not really exist on the target print server, Windows NT attempts to reach the print queue over every installed network redirector until they all timeout (usually 40 to 60 seconds). After all attempts have timed out in the redirectors, Comdlg32.dll assumes the print queue name was specified incorrectly and substitutes the default print queue port name, which is never truncated.

MORE INFORMATION

PrintDlg can be called in two distinct modes:

  • To retrieve the current default print queue information.
  • To open the print settings dialog optionally specifying the default printer name.

If an application uses PrintDlg to retrieve the default print queue name and the default printer name is longer than 32 characters, the name will be truncated.

For example, a 34 character print queue name such as

   \\Red_dog\pq-mc0838-hplj4sib-3-081

would be truncated to 31 characters such as

   \\Red_dog\pq-mc0838-hplj4sib-3-

Truncation of long print queue names occurs because the print queue name variable in Comdlg32.dll is limited to 32 characters in length. This limitation has it's roots in the Windows 3.x products where the maximum length for a device name was 32 characters and is documented in the Win32 SDK (Software Development Kit).

RESOLUTION

Obtain the following fix or wait for the next Windows NT service pack.

This fix should have the following timestamp:

   11/24/97  02:47p               365,328 comdlg32.dll (Alpha)
   11/24/97  02:50p               189,712 comdlg32.dll (Intel)

NOTE: Service Pack 3 must be applied to Windows NT 4.0 prior to applying this fix.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. A supported fix is now available, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

Keywords          : kbbug4.00 kbfix4.00 ntprint NTSrvWkst kbprint
Version           : WinNT:4.0
Platform          : winnt
Hardware          : ALPHA x86
Issue type        : kbbug
Solution Type     : kbpatch


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Last reviewed: December 4, 1997
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